Why is one of my subdomain's CNAME "destination" set to bodis.com advers?


Error Message

The URL is changed and users end up on a bodis.com URL with adverts.

Other Information

I got a reminder to renew my SSL certificates today for my 1 domain and 3 subdomains. I did this successfully for my 1 domain and 2 subdomains with no issues.

However, in the process I noticed that my third subdomain’s CNAME Current Destination is set to “11776. bodis. com”, a “Not ready” red label next to it, and the information: “Please note that DNS changes can take a few hours to take effect.”

I already tried to Setup CNAME records automatically, but get a message that " All CNAME records are already set up, no changes were made. Please wait for DNS propagation/caching." I know I will have to wait 72 hours for these changes to take effect, during which time the users of my website will be redirected to these bodis adverts…

What I would like to ask is: why did this happen on the first place? And what can I do to prevent this from happening in the future?

Can you screenshot your current CNAME entries?


Sounds similar to this

KangJL, thank you for your answer. I have already tried all the things suggested in these threads, and reading SSL creation problem probably due to DNS , it looks like the problem was resolved by the Admin in the end. How can I contact the Admin to ask them for help?

Hi Greenreader9, see above screenshots.

All I did was go into the control panel and delete the CNAME records from there, and then hit the installation automatic installation button in the client area again. Could you please try that yourself and see if it works for you too?

When I tried that in the other topic, the new records were live in seconds. The client area does have a short cache on DNS records though, so you can also verify it with another DNS lookup tool:


Hi Admin, thank you for your answer. I did what you suggested and at first I thought this worked, as I got a confirmation that my certificate is issued, and is valid till June, I installed it, and it says it is installed. However, the website is still marked as insecure and takes you to the same advers. I can’t figure out why.

Please start by reading our instructions in full.

On the page where you can view the SSL certificate that was obtained, you can first see the certificate, then install it, then verify that it has been installed, and there are a few boxes with text below that. Those boxes contain additional information on what to do next.


Hi Admin. I have been following the instructions very carefully, but still have a problem. Here is what I have done so far: 1) I received an email that a new certificate (which expires in June) has been issued. 2) I followed the link to the page with the confirmation and information what to do next. There I clicked " Install SSL Certificate automatically" - I did that last week, and tried this today two times- each time waiting for considerable amount of time before I check whether it has resulted in successful installation- but I get the following: 3)On the “Verify Installation” section, I can see that the installed certificate is my previous Certificate (which expires in April), and not the new one. I have checked the private key and certificate in my Control Panel/ SSL/TLS and they match my new certificate.

4) I have done the step “check if your website uses https”, and it does. The problem is that even in the secure version, I have those adverts appearning instead of my content.

Due to this


Can you remove subdomain from hosting account then add it in again?


So you completed step 4 and step 5. Now please scroll down and read Step 6?

Again, please follow the instructions in full. Don’t skip halfway the page.


KangJL, thank you for your suggestion. I tried removing the subdomain and then adding it again, but that didn’t resolve the problem.

Admin, thank you for your answer. I followed all instructions(including step 6), my htaccess file for this subdomain matches completely the instructions. The problem remains the same. I need to note that now on the Infinity Free’s page to set up the new SSL, on step 3:“Set up DNS Recorsd for hillfieldspark.fishpondsbristol.uk” my Current Destination matches what it should be, and is no longer “11776bodis.com”. However, any other third party tool shows that actuallty, my Current Destination is still “11776bodis.com”.

2 possiblities…either you did not do it correctly or there is something wrong with hosting…strange

I searched further for possible causes and solutions. I found this related forum topic Unwanted parking , in which there is this explanation by a Senior Moderator of this forum:

"Bodis.com is a parking page provider. All unused subdomains on our nameservers are automatically linked to Bodis. So visitors who try to open unused domains will see advertisements, the revenue of which helps to pay for the free hosting infrastructure.

As soon as you add a subdomain through our control panel, our nameservers are automatically configured to remove your domain from Bodis and add it to your website. However, if you’re using your own nameservers, you will need to do so manually."

I contacted Bodis directly to ask them to remove my domain. I found their contact details. This is what they answered:

" Hello Teodora,

Thank you for contacting us. It appears that your host (NS: NS1.EPIZY.COM, NS2.EPIZY.COM) is forwarding your subdomains (hillfieldspark.fishpondsbristol.uk) to our parking server (11776.BODIS.COM).

If your host (epizy.com/byet.org) is forwarding your domains without your consent, please contact them and request that they update/remove these unwanted DNS records.

Thank you."

So in conclusion, now I need to contact Infinity Free and ask them to update/remove these DNS records from the ones they have given to BODIS without my consent.

How can I do this? Is there an official way to contact Infinity Free and ask this to be done?

In case you are wondering whether my name servers are configured correctly, I double-checked this and all seems fine.

Your domain is pointing to BODIS, which generally means that the system messed up when it was added to your account. Try removing the domain from your account and adding it back again. Even if you already did it once, its worth another shot.

1 Like

Hi Greenreader, I have tried to remove the domain and add it again about four times now, and it doesn’t change anything…

As mentioned above:

"So in conclusion, now I need to contact Infinity Free and ask them to update/remove these DNS records from the ones they have given to BODIS without my consent.

How can I do this? Is there an official way to contact Infinity Free and ask this to be done?"

Can anyone here help with this?

I’m sorry for the delay in getting to your issue.

This is indeed an issue on our end. A server admin has fixed it now though, so your subdomain will start working soon if it hasn’t already (due to DNS cache).