SSL Certificate Request Keeps failing

Username (epiz_31961351

(please specify the website or account you are asking about)

Error Message

SSL certificate error:

(please share the FULL error message you see)
The provider encountered an error verifying the DNS settings of your domain name. Please double check your nameserver settings and try again later.

Other Information

I have double checked the name servers where my domain is registered and they are correct i.e. and

(other information and details relevant to your question)
I have double checked the Cname entry and it is ok

Current destination address is correct and READY

The message displays; SUCCESS Your certificate has been requested and will be available shortly

The message displays at the bottom of the screen: we’re requesting you SSL certificate. Please do not remove the CNAME records until this is complete. You can refresh this page to see if the certificate has been created

I have checked the DNS propagation and all is ok i.e. CNAME and Name Servers

When I refresh the page the error message I listed above appears

I have tried 4 times to verify domain and each time it fails

I tried deleting the add on domain and re adding it and tried to verify again with the same error

Many thanks

Nigel B


Hi editor
There was nothing to help from the hyperlink

Welcome :hugs:!
Are you using let’s encrypt? You might’ve been rate limited. Please try with another ssl provider.


hi jaikrishna.t

ok I have used a different ssl provider, double checked the Cname entries
Will wait until current destination is ready

The error message is accurate: Let’s Encrypt says that it cannot find the validation TXT record for, which should be (and appear to be) added by the client area.

We’ve been seeing more issues like this recently, but so far I’ve been unable to find out what’s causing it.


I tried GoGetSSL and received an error
SSL certificate error: The order got stuck at the provider or took too long to complete. Please try again later or try a different provider.

I dont have any other options
What can be done to fix errors for Lets Encrypt or GoGetSSL


Try zerossl


11 posts were split to a new topic: SSL request failing

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.