SSL request failing

I have similar problem with the SSL certicates. Initially I tried using"Let’s Encrpyt" and keep getting error message like DNS settings not correct.

Fed up, I tried installing ZeroSSL and it worked but only for a night. The next day, i tried to login to my website and my wordpress admin account but got an error like “404 page not found” or “SSL Server Authority not trusted”.

I have since switched to GoGetSSL and it seems I still have the same problem as when i am using ZeroSSL.

Can the admin here please help me?

My domain name is Thanks.


Website is loading fine.

Did you clear the browser cache??


I tried using incognito tab, it still doesnt work.

I tried accessing and I got the error message that the SSL certiicate is not a trusted authority.

For some reason, it is working fine now. I hope it stays this way. Thanks.

I got the same error message again when i tried to go into wordpress admin.

Can someone resolv

e this issue for me?

No issue



Can someone from the admin resolve this SSL certificate issue for me? The error message is the same and I used the SSL checker tool on Godaddy to check on the certificate and there is a message that says “Intermediate/Chain certificate not found”.

This is not supported on free hosting

Since you have a custom domain, you can use this guide


This is normal and fine.
As long as your browser can select the Intermediates and CA, it is fine (who most modern browsers can).

Also make sure your device’s certificate store is updated.


Ok, it is working fine now. I am using 5G instead of wifi now. It doesnt seem to work on this particular wifi network. Yesterday night when i was using my home wifi, there is no problem.

May I know the reason why it doesnt work on certain wifi networks?


1 Like

It seems that this specific WiFi network is using a web proxy that has a harder time validating certificates than modern browsers do. This unfortunately is a risk of using web proxies (and why I’m not a fan of such proxies in the first place).

So I would say that your SSL certificate is working fine and the issue is with the WiFi network, but they would probably argue the opposite.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.