Self Signed SSL Installation Issue

I was trying to connect with Cloudflare, but as of now Infinityfree does not accept Cloudflare’s origin server certificate I have installed “Self Signed” but it seems not been installed properly, I have tried manual installation but no progress even after waiting for 1 hour, and my website showing “parking domain name hosting” and SSL it still showing “Let’s Encrypt” as the current certificate.


You did not setup Cloudflare correctly:


It worked, but SSL is still showing “Let’s Encrypt”, even on a webpage, I hope its just an bug.

Screenshot 2023-11-13 002825

That certificate was probably issued by Cloudflare.

Your Self-Signed cert only protects communication from CloudFlares edge network to the origin server. Cloudflare issues a seperate certificate to secure the connection between them and your visitors.


I am using universal SSL by Cloudflare as mentioned in infinityfree knowledge base It doesn’t allow Cloudflare certificate so I’m using self sighed for infinityfree, as you mentioned in your post, and after following the YouTube tutorial, I no longer have any connection issues.

1 Like

Cloudflare does indeed issue Let’s Encrypt certificates for their Universal SSL plan, for more information on which certificate authorities they use for their services, you can look at their documentation:


Thank you

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.