Nameservers + Cloudflare

Site URL


On cloudflare DNS i have created two NS records both pointing to and ns2 --. This being said I am still unable to add comain to cPanel. I’m able to change it directly from the registrar site but am i able to leave them on the cloudflare nameservers and manage dns from cloudflare and point it here?

You will want to setup A records on Cloudflare, not NS records.


Yep im aware that the control panel cloudflare is bad, I’m using my own account from normal cloudflare. This is a custom domain.

So to be straight inbtead of NS records I use A records? how would that work?
so points to ns1 and another A record pointing to ns2.

This most probably will not work here

This is what you need to do

The OP wants to use Cloudflare, not Infinity’s nameservers.

@CoolGozo69, follow the guide I linked if you want to use Cloudflare.

Oh i didn’t realize it was full guide, I thought it was a blurb. I will read through and attempt and let you know.


Right, but in order to do that domain still need to point to and first.
Once domain is added to hosting account, then your guide will come in handy. OP obviously did not read

Oh now connecting to the site it redirects me to:

What A records are you using? In order to get the IP to use, you need to add the domain to an InfinityFree account first.

As the guide states, you must have the domain added to an account. You need to change your nameservers at your registrar to and, add the domain to a InfinityFree account, then follow the guide correctly.

Oh damn. I forgot to do that

Just added ns1 and ns2 to registrar and added domain to infinityfree and now getting this error. nameservers still in place and ip and hosting volume is set

Please note that bumping topics is in violation of the community guidelines.

Also, note that DNS changes can take 72 hours to take affect, so you may not see your site for a few hours.

In any case, it’s working for me, and displays the text below.

eoin is cool

1 Like

Yeah, that’s the index html file. Howcome for me it’s not working? Cleared cookies and refreshed with f5 and still the same. And if i dont add http:// before typing domain it gives protocol error when usually it just redirects to http - could this be htaccess file?

Try this?

  • Open CMD (if windows)
  • run ipconfig /release (your internet my get disconnected)
  • again run ipconfig /release

Probably, or get a free SSL certificate for better security.

still shows me a 404 page, are you able to connect? I’m gonna remove everything off cloudflare and set it to default

Yes, I am able to see the website with the text = eoin is cool.

works for me when translating it in google translate and adding link.
But somehow it’s on my end. Can you think of any fixes i’m at a loss.

Restart your machine, restart your router, wait till your ISP cache is reset or try from another device or network.

tried on another device same network and same issue. others on different network it works. connected to mobile data on that same device and the issue was fixed. it’s my home network.

ISP cache normally stays for 24 hours. So just wait another day?