Freenom domain not working with infinty hosting

My website URL is:
(I know its kinda wierd, but my friends and I wanted to make it as a joke so we just went with this)

So what my error is basically that infinityfree is not detecting my namerservers on my Freenom domain.
I got my Freenom domain and changed the name servers about 32 hours ago(at the time of posting) and I changed my namerservers to and, I waited a whole day to try it but it didn’t work, infinityfree keeps saying that the nameservers are not detected or changed. I think the issue may be that the nameservers are capitalized but I don’t know if that affects anything. I tried to make it lowercase, but it just auto capitalizes it. Any thoughts or advice to fix this?

It looks like your domain’s nameservers are not available on all networks yet (typical of Freenom). Try logging back into Freenom’s domain section and clicking the “Update nameservers” button about 3 times. This tends to solve the problem (it has for me in the past).

This is not a problem, as domain names are case insensitive.


Ok I will try that, do you have any idea of how long it could take?

1 Like

This is a Freenom issue, so your guess is as good as mine


5 posts were split to a new topic: Freenom Domain Issue

It is


Do you know anyway way to fix this or should I contact freenom for help?

HI, This sam, i have same issue with Freenom yesterday at 8 pm i was update nameservers but still show the same error,

" Your domain is not yet pointing to and Change your nameservers at your domain registrar and wait a few hours. You can also create an account with a subdomain first"

but when i am check in “Domain Checker” then its shows correct. please watch.

I have the same problem, it gives name servers error for 3 days.

I did all of that, but it still doesn’t work for me and it says it doesn’t have any namerservers.

Please bring this issue up with Freenom support, there is nothing we can do here.



Ok thanks for the advice I made a support ticket about 2 hours ago, here is the link if you want it:

Support links are private to your account, so only you can view it. Do keep us updated though!


Oh ok, I will

i still think infinity free is problem

A post was split to a new topic: Nameserver problem with GoDaddy Domain


See I think waiting about a week is best solution it’s freenom’s prob for sure

1 Like

Just to let you know, the Domain Checker is using InfinityFree systems and the nameserver validation when adding domains to accounts is handled by iFastNet. The InfinityFree and iFastNet systems are using different code running on different servers. So if both are reporting problems, you can be pretty sure it’s the domain that’s broken, not the checker.

My best guess regarding this issue is that one or more of the nameservers from Freenom (the registry nameservers, not the domain nameservers) is out of sync or down. This would explain why you don’t get results sometimes.


Ok, should I check back in a week to see if it works?