CloudFlare CDN using a plugin on a Infinity Free Subdomain

This topic is an extension of CDN not working

All CDNs are not working for my Infinity Free Subdomain website running Wordpress.

I tried all of them that are FREE (Shift8, Jetpack, CommonWP, and many more including the recent one I tried Optimole). They are all not working.

Is this plugin work for a subdomain? Super Page Cache for Cloudflare – WordPress plugin | Also created by Optimole.

I was actually having “headaches” about CDN since last month and still cannot add a working CDN for my website running Woocommerce.

Note: Jetpack does not run properly, so I stop using it. Yes Jetpack is fast (and also crashing my database) but I need to wait for 48 hours for my image to work on my website.

If this plugin does not work here (in a subdomain), please give me some suggestions that you are using right now for a CDN (that are not running in your purchased domains). Help me to solve my headaches. My target for this to be fixed is until tomorrow (UTC +8).

Correct. Don’t use that plugin here. It is poorly coded and used a ton of resources.

We know that Cloudflare works here. I have no clue about anything else.


Right now using this plugin “NGT jsDelivr CDN” and the results are this link is immediately generated[email protected]/wp-includes/css/dist/block-library/style.min.css after installing the plugin. Hoping tomorrow that it will make my site much faster and will also deliver most of the assets to the CDN. I guess jsDelivr’s sponsor’s server have a cookie support because it fetches one of my CSS.

Cloudflare is not my option now due to this:

But in any case, I am still using (or atleast if the plugin will work correctly) Cloudflare via jsDelivr.

Looking at the URL, I’m pretty sure it’s not fetching your CSS. It’s just fetching CSS from a copy of the WordPress core code. Any “common” assets can be retrieved that way, but your custom CSS, or the CSS from specific plugins, will not be published by these CDNs.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.