Woocommerce and Printful not connecting

Website URL


Error Message

Could not open Woocommerce authorization page (SSL certificate problem: unable to get local issuer certificate)

Other Information

Im trying to make my own merch by using WooCommerce and Printful, but it seems like im the only one having this problem where when i try to connect my WooCommerce account with my Printful account in wordpress’s dashboard, it keeps saying my SSL Certification cant be located when i try to connect the two. i used infinity free’s “Free Let’s Encrypt Certificates” add-on to add a Free SSL Certificate to my domain. i did everything right and my site says its safe and even has that Lock on the top left of my browser and the URL itself starts with https:// but for some reason WooCommerce doesn’t want to work, and without it i cant link my merch on my domain using Printful.

(Not sure if i gave all the right details for someone to help me out but i tried)
Side note: going free is the only option i have cause i have no money :')

I don’t think you can use Printful here. There was a topic some time ago from someone else who got a different error which also prevented them from using Printful.


Thank you, I’m kinda at a lost. is there any other alternatives that can help me make a shop other than Printful?

My goal is to make merch for my community and connect it to my Instagram, the only thing stopping me is actually adding items to my domain to then set everything up for the shop. I’m new to learning how to make my own domain/website and I’m willing to learn more:smile:




All I know is that the WooCommerce/Printful integration doesn’t work here. Maybe there are competitors to Printful which do work here, or maybe other platforms which integrate with Printful in a way which does work here.

Feel free to try to make it work, but don’t be too surprise if you won’t be able to.

Are you using one of our free SSL certificates by any chance? Since free hosting doesn’t support uploading CA chains, automated systems may get SSL errors like this.

You could try to enable Cloudflare on your website instead (using Cloudflare’s nameservers is recommended for this). Cloudflare’s SSL system works differently and may not have this issue.

If you are going to use Cloudflare with WordPress, please do make sure that both are configured correctly to work together:


Thank you so much, but im still getting the error and im not sure if thats because if i still have the same settings or whatever from the last free ssl

Here’s the one i used last time:
Annotation 2020-08-22 153848
and if you were wondering what tutorial i followed along:

im not sure if i did everything right without me knowing it and it still not working, or if it didnt change anything and the old one is still active somehow preventing me from getting this to work

my nameserver is under cloudflare and not the last one i used, but the site’s url Private key and Certificate are still the same, does that matter or do i need to find my new one? i have the lock at the top left and everything

is there something i did wrong with fully moving to cloudflare? or? :sweat_smile:

Could you please share the URL of your website at least? I only see the URL of Printful in your original post, which is already implied by the rest of the message. But that doesn’t tell anyone which website you’re having trouble using Cloudflare on.


yeah sure the ulr is https://ghostgxng.ga/ (nothing on it right now) and i have another one, it’s like a linktree type of thing but i dont have any troubles with that one

Your Cloudflare setup looks OK now. Please do note that due to DNS caching, it can take a few days for everything to start working.


Yeah I see now in my SSL Certificates, step 1 is telling me my DNS status isn’t ready so ill give it some time and continue through 2-4 after its ready then put in the new keys.

Hey it worked thank you so much for all your help, im glad that it was fixed by switching to cloudflare and now im able to continue where i left off! :')

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.