Why wont this work?

Username (e.g. epiz_XXX) or Website URL

(please specify the website or account you are asking about)

Error Message

Failed to load resource: the server responded with a status of 404 (Not Found)
eternalvale.infinityfreeapp.com/:93 Uncaught TypeError: thatDoc.registerElement is not a function
at eternalvale.infinityfreeapp.com/:93:21
at eternalvale.infinityfreeapp.com/:94:11

(please share the FULL error message you see)

Other Information

(other information and details relevant to your question)


You are calling the file http://eternalvale.infinityfreeapp.com/dnd/dmscreen/quickref.js, but it does not exist and returns a 404.

Also, you page is not valid HTML. You are missing the DOCTYPE, HEAD, and BODY elements. Because of this, all your code is going into the HEAD, and HTML that is meant to show in the browser viewport will not be rendered properly there.


My guy im looking right at quickref.js. Its in js folder.
2022-08-01 18_42_59-epiz_32294073@ftp.epizy.com - FileZilla
2022-08-01 18_43_08-epiz_32294073@ftp.epizy.com - FileZilla

The issue seems to be is depricated. Im not sure how to get around it.
Source : https://github.com/RemoteDebug/remotedebug-ios-webkit-adapter/issues/183

Look at the URL you are calling the JS file with. You are not calling it correctly. If the file is in a folder titled “js”, than the file path needs to match that.

Right now, this is the file path you are using: http://eternalvale.infinityfreeapp.com/dnd/dmscreen/quickref.js. As you can see, the “js” folder does not exist in that path. You need to update your code to call the correct file, and make it valid HTML, or you may run into more issues later.


So script src=“/js/quickref.js”></script


http://eternalvale.infinityfreeapp.com/js/quickref.js also returns a 404 error.


Got it sorry was posted on github, I added sub domains. I see what its missing.
dnd/gmscreen/js etc

script src=“dnd/gmscreen/js/quickref.js”></script` Is not working. What I am doing wrong?

That folder does not exist. Do you mean dmscreen?


Can you screenshot the entire FileZilla application with the js folder open? The anwser to your question will be in that screenshot.


I did yes.

I tried script src=“/dnd/dmscreen/js/quickref.js”></script just now.
The error is now
2022-08-01 19_07_22-eternalvale.infinityfreeapp.com_dnd_dmscreen_

Yea I can. Do you need the source code of quickref.js aswell?

2022-08-01 19_08_10-epiz_32294073@ftp.epizy.com - FileZilla

This is the correct URL http://eternalvale.infinityfreeapp.com/dnd/dmscreen/js/quickref.js. So the code should be:

<!DOCTYPE html>
    <title>PG TITLE</title>
    <script src="/dnd/dmscreen/js/quickref.js"></script>

Yup thats what Ive got. It worked on githubpages so Im not sure.

inline javascript (in HTML file)

now you need to somehow make thatDoc a function

it is not enough just to change thatDoc.registerElement to thatDoc.define

your function is intended to be an IIFE (Immediately Invoked Function Expression, which is a function that runs as soon as it is defined)


Got it. Will it not run without it? and any idea how I could make it a function?

1 Like

I don’t know what your website is supposed to do at all :slight_smile:

From the files I assume it’s a D&D game and map

Where did you download the source code from?
Is there a newer version of that code?
Or did you write everything yourself?

If you don’t know enough javascript (also scope) and other things
maybe it’s faster to find a more modern version of code online (that works),
rather than struggling to correct the code.

If something is old and has a lot of outdated methods
it is possible that it will give you an error in some other place again.


Nope just changed it up a bit. The exports were incorrect for non static websites. But I have absolutely no programming experience when it comes to javascript. I code mostly in java and c++.