Using InfinityFree with Namecheap's nameservers

I got the domain from Namecheap. I then setup email service for it with Google Workspace and it worked. I needed a simple one-page site at my domain, so I signed up with InfinityFree and created one with the site builder. I was told to change the nameservers to the InfinityFree ones and I did. This worked for the website (it was showing up at the domain), but messed up Gmail.

I found this thread – How can I use my domain here without using nameservers? - #7 by Greenreader9 – saying that once I had added the domain to a hosting account (as I had), I can move it back to another nameservers and point the domain to the Website IP of the hosting account.

So I changed the nameserver back to Namecheap BasicDNS, and under Redirect Domain I pointed my domain to (which is the Website IP that appears in my InfinityFree hosting account).

But now the website I created with the InfinityFree site builder no longer appears at my domain – or even at

Please point me to the steps I need to go through to fix this.

Hi there,
After opening your website, it redirects me to

This is incorrect.
Make sure you are setting up A records instead of redirects*.

I don’t know much about what kind of dns control is namecheap giving to you, but generally, it will work, if the records are correct.


Thank you very much for engaging with this! I do not understand your suggestion. Could you please clarify:

I currently have this:
Type | Host | Value | TTL
URL Redirect Record | @ | | Unmasked
URL Redirect Record | www | | Unmasked

When I enter my domain name, it redirects me to – so it seems the redirect is working correctly, but no site is showing up at – even though InfinityFree says this is the IP.

Doesn’t that mean that the problem is somewhere with InfinityFree not publishing the site to the IP address it is supposed to?

You’ll have to point to the website IP through an A record, and NOT with an URL redirect record. So remove the URL redirect records and follow this to add A records through Namecheap’s BasicDNS:

but only for @ and www, replacing with in this case when you follow this guide.


JxstErg1, thank you very much! Greatly appreciate it.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.