To many Redirects Cloudflare

Alternative mail

I have 2 questions: First one: I need to Verify MX records but it couldn’t verify it.
Second: How can i add Txt records in the Cpanel? Because i need to do that otherwise Receivers get warned for no reason.

Hope y’all can help me out

You can put MC records in using the MX tab under the Email section. Likewise, you can use the SPF tab under the email tab to add TXT/SPF records (since they both are just txt).


I don’t think ur right…

I need to add a DKIM record where i need to add a TXT Name and a TXT Value and that’s immposible in SPF or MX Records.

And for some reason the MX records just don’t verify while DNSchecker says that it works.

You can’t add DKIM records on the IF’s Control Panel. To add DKIM, you need to use CloudFlare (here is a useful guide: A Full Guide To Cloudflare).
If I remember correctly, on Zoho you can skip adding the record by just continuing without verifying it.



@wackyblackie is correct in saying that SPF records are the same as TXT records. So any type of TXT record (DKIM, DARMC, SPF) can be pleased in the SPF section.

MX records have their own space.

Unfortunately, DKIM is not supported here because of how checks are made, so you will have to use an external DNS provider like Cloudflare.

And please note that changes to DNS records can take 72 hours to propagate, so that probably explains why you cannot see the MX record from an external service.

Below is a guide to Cloudflare to help you connect:


Hey thxx for helping me out, I have setup Cloudflare properly as in the guide but now i get a To many redirects error.
How can i fix that?

I am seeing a bunch of 301 redirects on your domain name.

Can you please screenshot your Cloudflare DNS and SSL settings?



I haven’t setup any SSL Settings as far as i know. (Only in the Infinity Free panel)
Here is the screen of the DNS

Please double check your SSL settings for Cloudflare, because Cloudflare’s default SSL with WordPress’ default configuration don’t work with each other. The community guide covers that under the section “Set-up Cloudflare SSL”.


i think i fixed it right now.
I’m not sure but the site is reachable right now.
Maybe in a few hours the problem is back but for now it works.

Thanks for helping me out anyway!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.