This site can’t provide a secure connection

Username (e.g. epiz_XXX) or Website URL


Hello I keep on receiving this error and I dont know what is wrong with my infinityfree ssl. How can this be solved? I can’t even get on my admin page.

Unsupported protocol

The client and server don’t support a common SSL protocol version or cipher suite.

(other information and details relevant to your question)


That’s a bit of a weird error, can you share your URL?



What SSL provider did you use for the certificate?


I’m using cloudflare, and infinityfree ssl for full security. But for some reason I dont think its showing the infinityfree certificate anymore for me. Even when I try to get it back.

That’s likely the reason you’re having this issue. Cloudflare is known to cause this when SSL has not been set up correctly on your site.
Try issuing a new one and see if it fixes it.

EDIT: I just realized this is CloudFlare’s client area and not InfinityFree’s. Does your SSL appear in InfinityFree’s client area?


Hey how you doing,

I’ve been trying to issue a new infinityfree ssl but the ssl doesnt apear in the Infinity client area.

You need to install a certificate on InifnityFree:


I tried that.

Am I supposed to change the erase the cloudflare name servers from my domain site or something? I used freenom site.

Or you can just set Cloudflare to “Flexable”, it should work fine then.


I did that too actually.

I see the same error code, but in my own browser. So seeing how your domain is using Cloudflare, it means Cloudflare does not have an SSL certificate for your domain name to use on the frontend.

Cloudflare should do this automatically. Please make sure you have the “Universal SSL” option enabled in Cloudflare.

It’s also recommended to setup a certificate on your hosting account to secure the connection between Cloudflare and our servers. But that won’t fix the issue, this is a problem on the Cloudflare side.


Yea the Universal SSL is enabled on cloudflare. I also tried getting the ssl on infityfree again but it just doesn’t install.

Ok I tried disabling and enabling the Universal SSL again and right now its showing a 502 error.


if you have a self-sig cert installed on our hosting, then switch it to full
if you don’t have it then switch to flex




Oh great. It seems to be working all of a sudden. Thanks guys! I really hope it stays that way.

1 Like

I just need to solve a http 500 error on one of the tabs now. Ill check the other topics.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.