This happens whenever I add an addon domain

Website URL

I deleted the base domain and Im having a problem adding an addon domain

Error Message

This appears to be a subdomain you are adding (1008485) 86400 IN CNAME
There appears to be a CNAME entry for this domain (1408485) 86400 IN CNAME

Other Information

I’m doing that in an account that I just made a week ago or something, so I tried keeping the base domain, I also tried deactivating the account and using another one, but none of that worked. I even tried using the old account that I made few months ago ( and it used to work ) but it didn’t, it didn’t add the subdomain. Does anybody have a solution for that?

Please read this thread

1 Like

@KangJL, he’s using a FreeDNS subdomain, so there is no way he can add on his hosting account first before adding his subdomain. He might be better off adding it as a custom domain instead, but maybe also waiting for the DNS records to be empty again before adding his domain again.


I see, my bad


Yes, I had this message at first, that’s why I chose a base domain first to create the account, then I added the addon domain and it didn’t work.

Exactly, the problem is in the addon domain, it doesn’t add the subdomain and keeps sending me this error. In spite of that i added the nameservers to the subdomain.

1 Like

It seems to me that everything is working as intended. is the registered domain name. is a subdomain. You cannot add subdomains as addon domains.

The CNAME error is strange, yes. But even if we fix that, you still won’t be able to add your domain.

Yes, there was a bug that allowed you to do this. It also allowed you to do some things which definitely shouldn’t be possible. That bug was fixed, so now it’s no longer possible to add subdomains as custom domains.


Alright, it was an amazing bug though lol…

Anyway, my account got locked on FreeDNS so it doesn’t matter, because it doesn’t even add the ns to the domain I don’t know why it is restricted.

Thank you :sparkling_heart::rose:

Most likely you did not do this?


I sent an email then I got a reply from Spam Arrest telling me to verify the sender.
I verified it, I checked the “Send me an email confirming my verification.” box, and I didn’t get any email. So I don’t know if it’s sent or if there’s a problem.

Well, most likely you have to send a follow-up email after 2 months wait.
That’s what I did and obtained the approval


That’s too much wait, but Thank you anyway :sparkling_heart::rose: is a FreeDNS subdomain however, so are we to assume FreeDNS subdomains will no longer work? How about / These are registered domains too…


I think and PP.UA domains will still work as fine with free hosting as they’re considered TLDs on every single website that accepts domains.


I believe connecting to CloudFlare will also be an issue.
I had just added one FreeDNS subdomain successfully yesterday or the day before.
Maybe just before the loophole was plugged…


Yes, you won’t be able to add FreeDNS domains to Cloudflare. Both Cloudflare and the InfinityFree client area make use of the Public Suffix List to check whether a domain is a direct domain or a subdomain. And is not listed as a Public Suffix.

The control panel uses a different mechanism which may allow for such subdomains to to be used in some situations. But that’s not guaranteed to work or keep working.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.