SSL version of the website is not available

Hi, the https version of the website is not working

This site can’t provide a secure connection

dealz .great-site .net sent an invalid response.

  • [Try running Windows Network Diagnostics](javascript:diagnoseErrors()).


I’ve added the ZeroSSL and I see the following

The current nameservers of your domain are: ns1 .byet .org, ns3 .byet .org, ns4 .byet .org, ns5 .byet .org.

Record Name _acme-challenge
Domain dealz .great-site .net
Destination c85ee635-eda0-41dd-b87c-66040f39b956 .acmedns .infinityfree .net
Current Destination c85ee635-eda0-41dd-b87c-66040f39b956 .acmedns .infinityfree .net Ready

You need to add the CNAME records, then install the certificate before you can use HTTPS


You need to click on the “Request Certificate” button under the Current Destination field.


I’m sorry, but what URL are you trying to get SSL on?

Your free subdomain, or your custom domain?

If you are using the free subdomain, the records must be set in the control panel.

If you are using the custom domain, please follow this guide, because you are not doing it correctly.


I would ideally like to have both access to the free domain and via the custom subdomain, but the custom subdomain is more important. I’m really confused about those instructions

I have also tried setting an A record to on the CF subdomain

Hold on, let’s take a big step back here.

For starters, the domain is not assigned to any hosting account, nor is If you want to host either of those domains with us, you’ll need to add the domain to your account first:

Unless you want to do anything with the free subdomain (host a website, install SSL), don’t do anything with it. Don’t request SSL for it, it’s a waste of time if your goal is to setup your custom domain.

If you want to get our free SSL for your domain, you can, but then please go through the setup to get free SSL for YOUR domain, not for a free subdomain you don’t care about.

If you want to use Cloudflare, you can do so too. Please follow this guide to set that up properly:


You’ll have to change the nameservers to add it to your Hosting Account, but once you add it to your hosting account, you can change them back.


I’ve tried adding the domain to Addon Domains, Parked Domains and subdomain but it isn’t working for me.

1 Like

That’s because you are using Cloudflare Nameservers. You need to use InfinityFree (epizy) nameservers in order to connect your domain here.


A post was split to a new topic: SSL Help

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.