SSL Dosent work


I have tried 5-20 times today to make SSL work but it just writes:
The private key you are trying to upload is not valid.
The certificate uploaded is NOT for the domain name ( was seen) .

i dont now how to do so hope someone can help

Please read:


dosent work for me :frowning:

Do you use Cloudflare?

no but do i need it

Ok. Ignore the InfinityFree SSL error now, and follow the guide below to set up Cloudflare, than SSL in Cloudflare.

1 Like

Okay :slight_smile:

But it says that i shall delte other DNS from my Domain provider and i cant do that then i whold not be able to use Infinity free

You have a point, but that is why the “A” records are added later. As long as you already have the domain on InfinityFree (since you are trying to get SSL, im assuming the domain has an account), you can safely change the nameservers and continue to use InfinityFree as normal after you add the “A” records in cloudflare.

1 Like



nope still dosent work

Man the cloud flare thing dosent work my website is still not secure

If cloudflare doesnt work for you, we can try to set that up later. Can you use infinityfree’s certificates to start?

Remember that DNS changes can take up to 72 hours to take effect. So if you changed your nameservers to Cloudflare, you will need to wait ~72 hours before Cloudflare (and Cloudflare SSL) begin working.

1 Like

Where did you get this SSL certificate exactly? I checked your client area profile but there are no SSL domains there.

If you got the certificate elsewhere, please check with them to verify your private key and certificate are correct.

Or you can use our free SSL certificates tool anyways:


It still dosent work. Try to see again

Please show a screenshot of the SSL/TLS section of the control pannel.


Stop saying that. Show us what u did…

1 Like

I’m sorry, but what should we see again? All you provide is some error messages. I recognize the error messages and know what causes them, but without more information as to what you’re doing, I don’t know why you see that error message.

I provided you with the general explanation. If you want me to give a specific answer, I need a specific issue description. And “it doesn’t work, please fix” is not a specific description.

Let me start with a simple question for you: which SSL provider do you use? Where did you get the SSL certificate you’re trying to install?

In the certificate transparency logs, I see some Let’s Encrypt certificates being issued.

Judging by what I see there:

  • Please note that our control panel only accepts 2048 bits private keys. 4096 bits keys are not supported.
  • Wildcard SSL certificates are not supported by our panel either.