SSL certificate for Freenom domain installing throught Infiniti free?

Hello everbody at this great place,

my Q is following, use FREENOM - domain, paid domain, not free one, purchase .com domain throught , as they offer purchasing .com and other type domains, not only free domain, so as they don’t offer SSL certificate for their domains, planned to add some of free SSL certificated like , GetSSL or ZeroSSL=SSL for free, where need renew every 3 months, and though to add this SSL , as someone here mentioned throught Infinitifree free hosting where included free subdomains+free hosting, but couldn’t find all asnwers here how to do it in few threads here .

So, i did following,

  1. Added my .com domain to ZeroSSL to get cetificate by them, throught some very poor client panel at freenom could add values generated by ZeroSSL for CNAME at freenom client panel, and all ok, ZeroSSL verified ownership of domain, and issued certificate + private key.

  2. My idea is now, to add my .com domain as subdomain at Infinitifree account, and there throught Control panel, option SSL config, to upload private key + certificate for this .com sub domain, to solve SSL for this .com domain

please if someone with more experience and skills, if can help to solve SSL for this .com domain purchased at freenom through infinitifree account.


I’m sorry, but I’m totally confused. Did you buy a .com domain from Freenom and trying to get SSL here? If so, just use


For Question #1:
If you registered your domains at Freenom and set the nameservers to the epizy nameservers, you need to add CANME records through the cPanel at InfinityFree. Quoting Admin:

If it says Freenom nameservers there, it means you need to add the CNAME records to Freenom. If it says our nameservers there, you need to add them through our panel. If it says other nameservers, you need to it add it to those nameservers.

If you want to use ZeroSSL, GoGetSSL, or Let’s Encrypt, I strongly suggest using the SSL client at ZeroSSL and Let’s Encrypt use ACME, so you will only have to set up CNAME once, but that is not the case with GoGetSSL. You could also choose the “Self Signed” provider and use CloudFlare “Full”, which I highly suggest. Also read this article: A Full Guide To Cloudflare.

For Question #2:
You will have to add your main, top-level .com domain if you wish to make any subdomains and then you can follow the guidance from my above answer.

Don’t hesitate to reach out with any more questions!


Correct, purchased .com domain by Freenom, and now trying solve for this domain, as Freenom not offer SSL. Ok, will check what you suggested, even i need some help what to do after steps already performed, but tnx anyway :wink:

Ok, so just follow the guide below, and make sure you get an SSL certificate (At the bottom of the tutorial).


Thanks for fast response, yes, i purchased-registered my .COM domain (paid domain) at Freenom, and just need some ideas how to solve SSL for this .com domain to avoid using HTTP, but secure HTTPS, as Freenom by default not offer SSL, and couldn’t purchase by them, now problem is that domain is purchased there, and i need somehow solve SSL for domain purchased at them.

When you say CNAME records, you mean CNAME records for freenom .com domain provided by ZeroSSL need to add by CPL Infinitifree?

So, i need add custom domain .com here at Infinitifree Cpl, and then add Cname records ZeroSSL by CPL infiniti free, right, to solve verification and further installation of SSL, by uploading private key + certificate?

I don’t need any subdomain, main issue for me is to solve SSL for .COM domain purchased at Freenom in any way by help of Infinitifree :slight_smile: .


Tnx, i’ll do as you suggested, will read that guide, and try fix my problem :slight_smile: . :ok_hand: :+1:

  1. Set your nameservers to and at Freenom. (Last affair with Freenom)
  2. Add your .com domain through the cPanel here at InfinityFree.
  3. Go to dashboard and add your .com domain.
  4. Set up the CNAME records provided in the InfinityFree cPanel (or in CloudFlare).
    4a. Wait up to 72 hours for DNS propagation. It will most likely take much less time than that.
  5. Click the “Request SSL Certificate” button in the SSL Dashboard for your .com domain
  6. Copy the Private Key into the box for the Private Key in the InfinityFree cPanel.
    6a. Click “Upload Key”
  7. Once the certificate has been generated, copy the Certificate into the Certificate box
    7a. Click “Upload Certificate”
  8. Clear your browser cache and reload your site over HTTPS.

Top! Thank you very much for very clear explanation step by step, for noob like me in this SSL stuff, but i learn fast :slight_smile: .

Already read whole thread of @Greenreader9 about solving SSL by Cloudflare, and already added there my .com domain, get name servers by Cloudflare, added them at Freenom Control panel, and now wait they “apply” to be able continue further at Cloudflare.

But seems this way you explained by Infinitifree CPL even more simple :wink: !

BiG TNX once to you and @Greenreader9 for great help!


Be sure to mark @wackyblackie’s above post as “Answer”. That will help out future members of this forurm

You need to change the category to “Hosting Support” to do this.


How to mark it as “Answer” ? Probably you mean as solution for my Q.

Worked @wackyblackie suggestion and your @Greenreader9 Cloudflare option worked too, solve SSL for freenom domain thank to both of you , tested both solutions :wink: . Big tnx!

Have 1 more Q, is there any way to cloak paid custom domain, which added here at Infiniti Cpanel, in some way by using .htacces file?

Cause whe use “Redirect url” option from Cpanel it redirects my custom domain added at Cpanel to my 2nd domain where i use hosting fro my web this way,

redirectMatch 301 ^(.*)$ https://myhostingdomain/sitepage/

where https://myhostingdomain/sitepage/ is link of my website domain at hosting, which i would like to hide - cloak, like it’s possible by using freenom domains, they use redirect in 2 way “frame”-cloaking style or redirect 301 forwarding, and then when i type freenom.domain at browser not visible other paths when browse web, but only freenom domain, cause using this standard redirect from Cpanel it redirects my paid custom domain to domain of my 2nd domain-where website hosted, and then that 2nd domain is in browser visible, instead this Custom doamin added here at Infintii Cpanel.

Tried edit .HTACCESS this way,

  1. RewriteEngine On
  2. RewriteCond %{REQUEST_URI} ^/$|/)"
  3. RewriteRule ^.*$ / [L]

didn’t work, tried few other similar ways, no one redirect in way that whole time in browser shown URL of Custom domain from Infinitifree cpanel, while browse content of my website with it patsh-url “cloaked” in browser-hidden.


So you want to hide your custom domain and redirect everyone to your sub-domain?

Or do you want to hide your sub-domain and redirect everyone to your custom domain?
I’m a bit confused.


My apologize for confuse writing, as English not my native language :frowning:

So, point is following Domain 1 = .com pain domain, which i added here at Infiniti as Custom domain , using option redirect-forward url to other domain from Cpanel works ok, but i don’t like to be visible that other domain let we call Domain 2, but prefere in addres bar-browser to be only visible Domain 1.

Point is redirect Domain 1 to Domain 2 website, but keep the original url of Domain 1 in the address bar.

Hope this time i’m more clear, and this can be done usual by .HTACCES through some short script , like something i wrote in previous post, tried more combination, but can’t find one which will forward Domain 1 - Custom paid from Cpanel to Domain 2 web, keeping original URL of Domain 1 in browser.


Done :wink:


To answer about this Q by myself, as found solution by googling about this matter, and reading infinityfree threads about this matter too, as @Admin posted in few threads that at Infinitfree frame forwarding url by Cpanel not supported and even not supported by .htaccess file, as we need use proxy option if used .htaccess and some other options, but @Admin confirmed it’s ok do it throught index.html file framed forwarding url :wink: , so solution below, use this html code in index.html file, in our case at Infinitifree is index2.html file, add this,

tried post here, but forum strange formatting do for this html code…

as now most of browsers not support old frame formatting, need use this iframe, cause of html5 mostly used, tested already this code + custom domain added at Infinitifree and it well forward framed url :wink: .

Why can’t you just use “Parked Domains” in cPanel? I think this is what you’re trying to accomplish.

1 Like

That’s ok, if you use as frame forward url of whole domain, then parked domain is ok, but when you use some hosting where you get link like, , it not work ok, and then only good way is framed forwarding url, as when we use standard redirect 301, at adress bar is visible redirected domain-link, instead what i want in this case to be domain1 in adress bar, and not link2-domain2.

Hope now is more clear to you, why parkied domain from cpanel wasn’t solution in this case, but had to use modifying index2.html , as explained above, however tnx for idea, i already tried parked domain in this case, but not ok, and specially cause at this 2nd domain-hosting, don’t have access to modify name servers, as it’s requested to add name servers of Infiniti free for verification parked domain.

Solved automatic redirect HTTP to HTTPS , as my custom domain was without SSL, so after adding SSL by help of great Infinitifree stuff, now when SSL cert installed, made it automatic redirect HTTP to HTTPS secure, SSL, below how to do it,

in .HTACCESS file for our custom domain at Infinitifree need add these lines,

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$$1 [R,L]

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.