SSL certificate error: The provider encountered an error verifying the DNS settings of your domain name

Username (e.g. epiz_XXX) or Website URL

Error Message

SSL certificate error: The provider encountered an error verifying the DNS settings of your domain name. Please double check your nameserver settings and try again later

Other Information

I chcecked my nameservers and they are set to NS1.EPIZY.COM and NS2.EPIZY.COM

Hello, and welcome to the forum!

Are you using the Free SSL tool from InfinityFree? External SSL tools do not work well here.

Please let me know if you have any questions!

Yes, the provider is “Let’s Encrypt”

Can you please screenshot the error message?

Your nameservers are correct, so I don’t know why that error is showing.

Can you try using ZeroSSL or GoGetSSL until Admin can let you know what is happening?

ok, I will try

Tried zeroSSL, this is what happens

What does GoGetSSL say? Hopefully Admin will be able to explain that further.

The SSL tools is known to have bugs after the recent client area upgrade. Hopefully it’ll be fixed soon :slightly_smiling_face:.


Our DNS servers had some troubles yesterday which likely affected SSL issuance too. Those issues have been resolved, so you should be able to issue certificates without problems now.

1 Like

Does Infinityfree have own dns server or is that like issue with iFastNet :thinking:

This issue was with iFastNet’s DNS servers (the ns1/ / ones). One of them was down for a few hours yesterday, which may have resulted in some failed checks.


Oh, so basically nameservers are aliases of, right?

Yup, ns2.epizy and ns1.byet are the same


It still doesn’t work for me. Different error, though.

Try CloudFlare then

I just checked and this is not a DNS issue.

The issue seems to be that Let’s Encrypt is refusing our orders because we have too many active orders already.

This is not a problem with your domain name. This is a problem with Let’s Encrypt not letting us request more certificates.

If you try a different SSL provider, you should be able to get a certificate. At least until we figure out how to work around this.


Tried ZeroSSL, same thing

I am experiencing the same problem.

My domain: (it was previously with the same issue, I re-registered another domain, and yet problem is not solved)

I tried ZeroSSL and Let’s Encypt and provide is the same. What’s going on?

Please help!