Setting up email address with Zoho


MX verification failure

I have added the MX data to the relevent area within account. It just fails to verify. I have seen that cloudflare could be the problem. A friend said to log in to cloudflare and disable it. I don’t recall setting up a cloudflare account when setting up with infinityfree. I tried the login details of my infinityfree account but that failed. How do I get this MX thing working so I can get and send emails with Zoho?
Not a very technical person so please be kind and helpful where you can. Any help is very very greatly appreciated. Many thanks.

Since your question is vague, this is the best to help you

Sorry. Didn’t really know how to word it properly. I have got the html page uploaded and that part works. But with the MX records, it’s failing to verify at that point. I have finally got access to the Cloudflare site and I might just remove my website from it to see if that helps. I have added the MX records to the inifinityfree cpanel as stated in the instructions in Zoho but, like I said, just fails all the time. Thank you anyways.

If you are using CloudFlare, you should add the mx record in CloudFlare

1 Like

Hi there. Thank you but where in Cloudflare do I add this? I click DNS within the account and all I get is:

Partner hosted zone

Your DNS zone file is hosted by Byethost, a Cloudflare partner. Manage your DNS records at their website.

Would I be correct that if I go to this Byehost site it will be the same passwrod etc?

Using CloudFlare integration within Vpanel has a tendency to mess up your website and hosting account.
That could explain why MX record does not work.
Disable it through


Ahhhhhhh… thank you. I was looking for the disable cloudflare and for some reason I could not see it. Thank you. I have now disabled. Just gotta wait up to 48 hours now. Hopefully it will sort it out. I will delete the ones I have added and will add again within the next couple of days just incase I need to. Again, thank you.

1 Like

Welcome :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.