Problem editing wordpress site after changing to http

Hi, I recently changed my website to a http URL, according to @Ergastolator1 instructions here. As I wrote there, everything on the site is working, but I can’t seem to edit pages. Can this have been caused by changing the URL? And what can I do about it? Thanks very much!

My website URL is:

What I’m seeing is:

Getting WordPress to work correctly with Cloudflare Flexible SSL is always a bit messy. There are various approaches to getting it to work, and all have their faults.

I just did some testing myself, and I had good luck with the following:

  1. Enable Cloudflare on your domain and make sure it’s configured to Flexible SSL.
  2. DISABLE Automatic HTTPS Rewrites and Always Use HTTPS. Especially the first one is a rabbit hole of errors which should only be used as a last resort.
  3. Enable the “Really Simple SSL” plugin and hit the Activate button in the plugin.
  4. (Optional) Turn on “Enable 301 .htaccess redirect” in Really Simple SSL and/or Always Use HTTPS (NOT REWRITES) in Cloudflare. Use one, both or neither.

With this, I didn’t have any issues with the editor or with redirect loops. Can you see if hits works for you too?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.