Please help - Problem Enabling https

Aaaah I see.
Ok, let me try adding SSL certs to the subdomain. If that works, I might look into migrating WP so I don’t have to do both. Thanks. I’ll report back.

Take note if you migrate, you will need to change your custom domain from parked domain to addon domain


Yes, I’m aware of this. Thanks. I’m actually just going ahead with the migration option instead. Still on it now…


No luck. I must be overlooking something somewhere.
I added my custom domain as an addon domain (removed it from parked domain).

  • First copied all files over to the new domain, site launched fine and all, but still insecure.
  • Activated Really Simple SSL plugin, broke site
  • Regained access through database, then purged cloudflare cache. Back to insecure
  • Completely removed site from cloudflare and re-added it. Same thing - still insecure
  • Deleted all files under new domain, installed WP from scratch and migrated files over
  • Tried again, same thing - insecure and if Really Simple SSL is activated, site is unreachable

Not sure what else I could be overlooking…

Really Simple SSL can’t install SSL Certificates on our platform for various reasons. You’ll need to manually install an SSL from Login to your account - InfinityFree (I recommend Self Signed issuer) and then install it with cPanel. After you do that, you can set your CloudFlare SSL settings to Full and then install Really Simple SSL. You can also use automatic http rewrites in CloudFlare.

Please let me know if you need any help! Thanks!


If it’s on the same hosting account, just use filezilla to drag the files over. Is faster this way.

Since you are using CF, not really needed


Thanks. I did this and it seemed I made some progress - site shows up as secure but contents are all over the place. I then tried Really Simple SSL and everything went south. Can’t access the site. Message shows Cloudflare is fine but error is on the host’s side:

Thanks. I did this and I was in fact able to get to the site (like I mentioned earlier). But the issue was not fixed, so I just though to start all over. Still stuck though. :confused:

That error happens when your Cloudflare SSL settings are not correct. Can you please make sure it is set to “Full” and not “Full (Strict)”?

If you want me to check your site, can you share the domain name?


@Greenreader9 Thank you. I looked through Cloudflare and turned off “Always use HTTPS”. I also deleted Really Simple SSL. completely. Now the site loads again, but it’s back to insecure status… lol.

I know this makes it harder to get the help I need, but unfortunately, I’m not at liberty to share the domain name; I’m working on this for someone. Hope you understand.

Just to clarify, the A records in Cloudflare should point to the IP address of Infinityfree server, right?

Also, I’m thinking maybe I’m missing a step or two in the SSL generation. Here’s what I’ve done:

  • I generated a free SSL from
  • After generating, I clicked “Install”. Ensuing page shows it’s installed
  • Then I went to SSL section in cPanel (because site still wasn’t secured) and I clicked to "Generate Key/CSR) - not sure if this was necessary

Instructions I’m reading appear to suggest that the key/CSR combination needs to be sent to some ‘vendor’ who would then provide me a Certificate that I’d need to upload. Am I right? Is this necessary in my case? I feel like I’m bungling something.

You can click on the profile picture of @Greenreader9 and click on the message button. You can then send a personal message to him/her.

1 Like

Should point to the IP of your hosting account

You still need to install the private key and SSL cert

Definitely not necessary


I checked your site (really hard to find, but you neglected to omit one identifier from the information you shared).

The page mostly works, but I’m seeing some mixed content errors. Seeing how you’re using Cloudflare, please make sure that:

  • Automatic HTTPS Rewrites is turned OFF. You shouldn’t need it, and it tends to cause weird issues.
  • Your website is configured to use HTTPS (by hand or with the Really Simple SSL extension).
  • You have an SSL certificate installed on the backend server and are using Cloudflare in “Full SSL” mode, or are using Flexible SSL with Really Simple SSL.

Thanks @KangJL!

I read through that post again and indeed, I skipped the part where the key and the certificate have to be uploaded individually. Silly me! So I went ahead and uploaded them. For some reason, didn’t work on first try (checked site with https and was getting the error page). Then went through the steps again carefully and bingo! This time, it worked!!!

Thank you so much for your patience!
@wackyblackie @Greenreader9 @jaikrishna.t Thanks kindly for your inputs and guidance! Going on almost 3 days now battling this thing, but finally it’s done. I am very appreciative! :innocent:


@Admin Thanks a million! Got it to work last night and tried to post above message, but was barred by the new-member rule, so had to wait 8hrs… lol.

I truly appreciate all the help. Thanks everyone!


No problem, glad you got it working :slight_smile:

1 Like

Looked like battling COVID 19 in 3 days :sweat_smile:

1 Like

:joy: :joy: :joy:

1 Like

You are welcome :slight_smile: