Please help - Problem Enabling https


I just recently signed up for hosting. I initially built my site on the auto-assigned infinityfree subdomain (using wordpress). Then I purchased a domain and parked it as per instructions so requests are forwarded to the infinityfree subdomain. Everything appeared to work fine.

Next, I added my domain to cloudflare (changed infinityfree’s nameservers to cloudflare’s nameservers with my registrar as required). I didn’t run into any issues and checking my SSL, it appears to work fine. However, my site still shows as insecure. I’ve tried all suggestions for the past 2 days and still not making a headway. If I check the site on http, it works fine (but of course with the insecure page warning). If I try https, I get an “ERR_SSL_PROTOCOL_ERROR”.

I’ve checked SSL on my site using several different tools and it passed in every single case. If I use the Really Simple SSL plugin on Wordpress, it breaks the site. And I have to go in the database and reset the URLS.

What am I doing wrong? Please help.

You need to do these


Did you read?


Yes, I did actually. No luck, unfortunately. When I enable “Always use HTTPS”, the site is completely unreachable.

Any SSL installed for the free subdomain?

1 Like

No, I didn’t install any. Just registered for hosting, installed wordpress, then parked my custom domain and added the custom domain to cloudflare.

That explains why!!!

Do these for the free subdomain

“ERR_SSL_PROTOCOL_ERROR” you get is because free subdomain is lacking SSL cert


I’m confused. Are you saying I need a separate SSL certificate even if I’m using Cloudflare? Or Infinityfree specifically does not support Cloudflare?

CloudFlare is only for you custom domain. Free subdomain has no SSL installed.
Since WP is installed on free subdomain with no SSL, there is no way your custom domain (SSL enabled) can forward to free subdomain (non SSL).

Unless you migrate WP from free subdomain to your custom domain, you will need SSL for free subdomain as well


Aaaah I see.
Ok, let me try adding SSL certs to the subdomain. If that works, I might look into migrating WP so I don’t have to do both. Thanks. I’ll report back.

Take note if you migrate, you will need to change your custom domain from parked domain to addon domain


Yes, I’m aware of this. Thanks. I’m actually just going ahead with the migration option instead. Still on it now…


No luck. I must be overlooking something somewhere.
I added my custom domain as an addon domain (removed it from parked domain).

  • First copied all files over to the new domain, site launched fine and all, but still insecure.
  • Activated Really Simple SSL plugin, broke site
  • Regained access through database, then purged cloudflare cache. Back to insecure
  • Completely removed site from cloudflare and re-added it. Same thing - still insecure
  • Deleted all files under new domain, installed WP from scratch and migrated files over
  • Tried again, same thing - insecure and if Really Simple SSL is activated, site is unreachable

Not sure what else I could be overlooking…

Really Simple SSL can’t install SSL Certificates on our platform for various reasons. You’ll need to manually install an SSL from Login to your account - InfinityFree (I recommend Self Signed issuer) and then install it with cPanel. After you do that, you can set your CloudFlare SSL settings to Full and then install Really Simple SSL. You can also use automatic http rewrites in CloudFlare.

Please let me know if you need any help! Thanks!


If it’s on the same hosting account, just use filezilla to drag the files over. Is faster this way.

Since you are using CF, not really needed


Thanks. I did this and it seemed I made some progress - site shows up as secure but contents are all over the place. I then tried Really Simple SSL and everything went south. Can’t access the site. Message shows Cloudflare is fine but error is on the host’s side:

Thanks. I did this and I was in fact able to get to the site (like I mentioned earlier). But the issue was not fixed, so I just though to start all over. Still stuck though. :confused:

That error happens when your Cloudflare SSL settings are not correct. Can you please make sure it is set to “Full” and not “Full (Strict)”?

If you want me to check your site, can you share the domain name?


@Greenreader9 Thank you. I looked through Cloudflare and turned off “Always use HTTPS”. I also deleted Really Simple SSL. completely. Now the site loads again, but it’s back to insecure status… lol.

I know this makes it harder to get the help I need, but unfortunately, I’m not at liberty to share the domain name; I’m working on this for someone. Hope you understand.

Just to clarify, the A records in Cloudflare should point to the IP address of Infinityfree server, right?

Also, I’m thinking maybe I’m missing a step or two in the SSL generation. Here’s what I’ve done:

  • I generated a free SSL from
  • After generating, I clicked “Install”. Ensuing page shows it’s installed
  • Then I went to SSL section in cPanel (because site still wasn’t secured) and I clicked to "Generate Key/CSR) - not sure if this was necessary

Instructions I’m reading appear to suggest that the key/CSR combination needs to be sent to some ‘vendor’ who would then provide me a Certificate that I’d need to upload. Am I right? Is this necessary in my case? I feel like I’m bungling something.

You can click on the profile picture of @Greenreader9 and click on the message button. You can then send a personal message to him/her.

1 Like