(no CNAME Found) for SSL Renewal

Website URL

(please specify the URL of the site on which you are experiencing the problem)

Error Message

(no CNAME found) Not Ready
(please share the FULL error message you see, if applicable)

Other Information

Hi! I am hosting my website, pimpleletta.com, through Infinity Free and since my SSL Certificate is about to expire next week, I created an order to renew my SSL Certificate, although I’m stuck at Step 3. I created the order last October 16, 2023, and I’ve read that DNS propagation may take up to 3 days so when I tried to check it again today, Oct. 19, I’m still at the same step. I’m already using the nameservers from InfinityFree (not from GoDaddy).

please let me know what I need to do to complete the SSL renewal. Thank you!
(other information and details relevant to your question)

Please see the pinned topic:


Hi, thank you for this. I opened the link which I modified to https://cpanel.epizy.com/panel/indexpl.php?option=cnamerecords since I’m not in Vista Panel and it shows that the CNAME Record for my draft order has been added but it still shows in my SSL Certificate page as Not Ready.

It says as draft in my page, will this change its status to “Issued” once the current one expires next week?

Could you please try to remove the current CNAME record through the control panel and then use the client area to recreate it? It seems as if something went wrong on the hosting platform and the CNAME record you see in the control panel wasn’t actually set up on the nameservers. Removing and re-creating the CNAME record usually fixes that.


Hi! I did what you told me to and I thought it was fixed and I see it’s now “ready”
but then it shows “Failed” in my Certificates page
I tried it again as you can see and it still shows failed.

I tried it again and will wait for a few hours before I click the Request Certificate button.

I’m no longer able to request certificate since it went back to “Not Ready”. I did the same process again, but now it still shows “Not Ready”.

Can you try using creating a new certificate using GoGetSSL? (under “advanced options”)

GoGetSSL automatically validates your certificate and InfinityFree won’t be checking your CNAME records (it goes directly to GoGetSSL).



Thanks, I redid the admin’s instruction and a new certificate has now been issued.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.