Mysql too many redirects

Website URL

Error Message


Other Information

I cant login to my sql database. If i Click “Admin” on the dashboard i am getting redirected to and the browser says “ERR_TOO_MANY_REDIRECTS” I tryed deleting all cookies and i tryed to login on other devices but it nothing is working.

Got the same error, guess its cuz the new PHP update. Happened an error with $_SESSION’s days ago and then they fixed it. Hope they fix it fast too!

It works fine for me; if you’re still facing this issue, check if anything in this article applies:


I am experiencing the same.

I cleared all cookies - problem still persists.

I logged in using “private browsing” - problem still persists.

I think this may be some issue on the server side.


Please use the “phpMyAdmin” option in the control panel to use phpMyAdmin.

The phpMyAdmin button on the database option and client area is currently broken.

Correct option in the control panel:

Don’t use the button in the Client Area until Admin says its fixed:

The client area phpMyAdmin button is now fixed!


I am also facing the same phpMyAdmin issue. I can’t login to the Cpanel with the link you provided. I have tried resetting the password but even with the new password, I can’t login. It does not say anything like “wrong password” or any other notice. I am logged into the client area. I tried to go to control panel from there, but also failed.

What happens when you click on the control panel button from the client area?


It appears that the phpMyAdmin URL was changed from an IP address to a domain name. That’s good, because phpMyAdmin now finally uses a HTTPS connection!

However, while the phpMyAdmin section in the control panel was updated, the MySQL Databases menus in both the control panel and client area were not, so those buttons don’t work anymore.

I’ve informed iFastNet about the issue in the control panel so they can fix it, and I’m preparing an update for the client area as well to fix it there. The client area fix should be live within the next 10 minutes. I can’t make promises for the control panel, but knowing iFastNet I expect that to be fixed some time today as well.


Which error are you facing?

You’ve posted both here and in How to Fix SSL UNRECOGNIZEDNAME ALERT Error - #13, and you don’t seem to be facing any SSL issues, so I am guessing it is the MySQL redirect?

Did you try the options mentioned above?


Thank you very much Admin. The problem has indeed been fixed now, and all is working as it should. :slight_smile:

Thanks SpookyKipper for this temporary workaround, which worked perfectly.

The main issue has now been fixed, but your advice enabled immediate access.

Your quick remedy was much appreciated.


I have successfully logged in now. Though I can’t login from clicking the control panel from the Client Area. It gives me this error:

It may be broke after the password reset. But at least I can login now manually.

But the phpMyAdmin problem is not fixed.

When I am clicking the connect now, it gives me this error: ERR_TOO_MANY_REDIRECTS

I badly need the database backup. My website is also down (500 Internal Error). So, I can’t create a backup from there.
Can you please provide a database backup?
Or will the phpMyAdmin be fixed soon?
Or, is there any other way to access the database like using some software?

Have you tried Adminer?

1 Like

Tried now. It did not work. Showing this error

It works fine for me, can you please try the fixes here:


I have already tried them. I tried logging in from incognito mode and even tried from completely new browser from where I never logged in to the infinityfree account. And I changed the password 2 times.

None of that worked. I also can’t logged into the control panel from the the client area. I needed to manually login using the new password.
It can be a case for also the database. Can I login to phpMyAdmin manually using my resetted password from anywhere?

This means that your client area and control panel password are not synced. You’ll need to change the hosting account password from within the client area to ensure it is properly synchronized:

This is definitely strange, as these extensions should exist…


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.