My website redirect me to a different place all together even though it has my domain name there

Website URL

(please specify the URL of the site on which you are experiencing the problem)

Error Message redirect to a different place all to even though the place has my domain name as heading that is not my website

(please share the FULL error message you see, if applicable)

Other Information

(other information and details relevant to your question)

Please remove domain from hosting account then add it in again


please wont that change my current host name and databases??

Not if you follow the instruction correctly.
You just need to move website files from htdocs to after domain is added to the same hosting account


ok thanks am trying that

I did that but didnt work, i just created a new free domain and it still redirect to that place

Of course it did not work.
Why did you change nameservers?


Make sure to do this


it was not that at first when it didnt work that is why i changed the name servers to see if ti will at least point me to an error or a blank space but that thing was still showing so i was giving it time to propagate and see if it will point me somewhere else apart from that thing but yet it still show me that
why isnt it showing me something else??

i have changed it back to NS1.INFINITYFREE.COM, 2 and 3 but still showing me that thing

Your domain name is currently pointing to the nameservers of

I’m confident we can fix this issue together, but please don’t point your domain name away from our hosting, because we cannot fix a site we don’t host.


that is why i changed the name servers

Every time you change the nameservers it resets the clock and you have to wait for hours (or days) while the DNS propagates across all the servers on the entire internet.


i noticed infinity free has a problem because when i changed it worked but now i have changed back and the issue is back, i really want to host with infinity free

Go to the Account dashboard

And create a new account (assuming you haven’t used all 3 of your accounts yet).

Set up a new domain and don’t install anything from Softalicious. After your DNS propagates and the account is set up… try to go to your new URL to see if the default page loads. You may have to put a test index.html file inside the htdocs folder.


<!DOCTYPE html>

If this loads, it’s not an issue with InfinityFree. The issue seems to be either your nameserver settings or some file located in your current site directory.

Doing a default test will verify that InfinityFree free server is working correctly. Also - every time you change your nameservers it could take 4 hrs to 72 hrs for the DNS to propagate. So changing your nameservers frequently is not recommended.

ok doing that now

1 Like

New one actually works
there is this issue too where i bought my domain when i fix in name server, it occasionally tell me unknown error occurred when after several try it goes though give it about an hour and when you come and check where u put the name server instead showing the name server the fields will be empty. can that also be the issue??

1 Like

The issue with your previous site sounds like nameserver issues.

On the site where you purchased the domain, you can edit the nameserver records.

You should only have 2 nameservers:

No others. Then, after the DNS propagates (could be many hours or even a day or two), go to your control panel on InfinityFree and scroll down to Aliases (Parked Domains). Then, where it says Create a New Parked Domain – type in the domain name you want to point to InfinityFree (e.g. Then, in the select list, choose which InfinityFree site you want to park the domain on to. The, click the “Add Parked Domain” button. After the DNS propagates, you should be able to type in your domain and see your InfinityFree site.

You can use a tool like “” to see if your nameservers are set correctly.

InfinityFree also has a domain checker tool here:

InfinityFree should be the only nameserver (NS) records that appear for your domain.

If you have a bunch of files in your ‘htdocs’ directory you may want to do the same test you did here earlier. Create a new folder called “backup” and copy all the files inside your htdocs folder into that new backup directory. Then, at the root level of htdocs, create a single file named “index.html” and put the test code you used earlier.

When you type your domain into a browser you should see the test file from your htdocs folder.

If that all works – you can remove the stuff from backup and restore it to the root level of your htdocs folder and see if it works. Keep in mind that if there is some file being referenced in your HTML which doesn’t exist (or which generates an error) – you’ll get an error page.

Make sure all your files are in the right location and are linked to properly in your code. Using the generic test file is a good way to make sure the server is working. Then, you can troubleshoot problems with your HTML code separately and get that working later.

The domain is added to your account, but something went wrong on our end which resulted in the correct DNS records for your domain not getting set up correctly on our end.

To fix this, you can do what KangJL said:

You don’t appear to have done so yet.

To be clear, you do NOT need to touch any nameserver settings. Just remove and re-add the domain to your account. That should cause the domain setup system on our end to add the right records on our end.

Note that it may still take up to 72 hours (but usually much less) for the domain name to start working.

I don’t think it’s related to this issue.

But Freenom is in quite hot water right now, they are in several law suits, have halted free domain registration since early this year and some of their free domain extensions got taken away from them entirely. All with zero direct information to customers. So if I were you, I’d want to transfer my domain to a registrar with a more positive prospect.

I’m not surprised their panel isn’t working well for configuring nameservers.


thanks going on with that

Do what the Admin says here first. You shouldn’t have to change your nameserver settings again.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.