My website doesn't update because of cache

Good morning, my problem is that, after changing some pages of my website, the users who access the website (and that already had visited it before the changes) see the older, not updated, version. I experimented by myself that this issue is related to the cache because after clearing it i can see the updated version of my website.
I read a lot of posts in your forum where users talk about this issue, but i haven’t found a good solution yet.
As you suggest, removing completely the cache through htaccess file is not a good idea because this would slow down the website.
Now, that’s the point, a website contains bug (which can be removed after proper testing), and introduces new functionalities and features step by step.
If users don’t clear the cache manually, they will continue to see the older version of my website potentially forever.


If you use cloudflare, they do give an option to clear all of the cache on your website. If you don’t use cloudflare, then try it. I’m sure you’ll like it.


Indeed. If you don’t like or want to use the .htaccess, then using Cloudflare is also a good idea for purging and removing caches from your visitors and update them, you know. But if you don’t want to use Cloudflare too, then there’s no way to remove the caches of the visitors automatically or by yourself or by your website.

If you are using Wordpress, then there is a plugin for it, like purging caches, expiring headers and disabling caching on your Wordpress site - W3 Total Cache.


Cloudflare also have their own Wordpress plugin.

Thanks for your help guys.
I tried to add my website to CloudFlare but here’s the answer:
Please ensure you are providing the root domain and not any subdomains
If i try to enter only it says:
This zone is banned and cannot be added to Cloudflare at this time.
I also tried to enable CloudFlare from my control panel of infinity free.
After i enter the complete domain name ( it appears:
Currently disabled Click to enable
If i click the enable button it appears the following
CLOUDFLARE ERROR : We were unable to identify [mySubdomain] as a registered domain. Please ensure you are providing the root domain and not any subdomains
How can i solve?
Edit: I don’t use WordPress or any other tool, my website is completely “hand made”


Yes, you can’t register subdomains. So try and register a domain from Freenom If you don’t have one.

Alternatives: You could try to use the Wordpress cloudflare plug-in but I’m not sure if it will work.


Top Tip: Try to post between 9am-7pm GMT because that’s when the forum is most active.


Registering a completely new domain will make my website go in conflict with infinty free subdomain (or not?). I mean basically if i register a new domain from Freenom what will happen to my website hosted with InfinityFree?
Sorry it may seem a stupid question but i’m new here and this is the first time i develop a complete website for real.
Also, thanks for the tip :grinning:

Hi there!

It depends how you configure the configurations.

Still remains intact unless you deleted DNS records or files.


If you created new domain to Freenom, point the nameservers to cloudflare nameservers. Then, create a cloudflare account, and enter the newly created domain. Then follow the steps after. Then add “DNS records” as it follows:

A ==> @ =>> Main IP Given by Infinityfree from account

A ==> www =>> Main IP Given by InfinityFree from account

*You can view your accounts main IP in the accounts area.


It is because you are using the infinityfree subdomains and not your own domain. Use your own domain so the cloudflare would be enable, you can get a free domain using


Another option would be to not use cloudflare at all and instead use Infinityfree’s SSL vendor.

The guides to add a new domain were useful a lot!
I created my own domain with freenom, i pointed the new domain to InfinityFree nameservers and i added it as an addon domain.

Now i have several problems:
Both the domains are not working:
Trying to access to [mySubdomain] → impossible reach the page

Trying to access to [myNewDomain].ml → Error 520 Web server is returning an unknown error:
You Browser: Working
Cloudflare: Working
[myNewDomain].ml Host: Error

Also, i cannot access anymore the file manager:
Error, could not read line from socket


pls tell the website url?

My own domain registered with Freenom:

The server still had a temporary problem or issue for now. Please wait for a little bit of time and then try again.

Another issue, today is not so lucky day ahahaah
The folder assigned to my new domain has disappeared from the file manager
Why this happened?

What do you mean? Like after you put or add your addon domain?

Yes, exactly. I added my new domain registered with freenom.
It worked for some hours but now the folder which contained the files has just disappeared.
I don’t know if it can helps, but right after tranfering the files into the folder of the new domain (/myNewDomain/htdocs), i deleted all files inside the main htdocs folder (/htdocs), because i would like to have the website working only at [myNewDomain].ml and not at both [myNewDomain].ml and [mySubdomain]

so you deleted all your files from your old domain?

Yes but they reappered as for magic (while the folder of the new domain disappeared)

I solved this last problem eliminating and adding again the domain in the section “Addon Domain”.

I have a completely “hand made” website (without WordPress or Wix or others), and i want to host it with InfinityFree
Initially i created a subdomain ([mySubdomain], but i want to use CloudFlare because it helps with the update problem due to cache.
So I created a new domain with Freenom (, and I pointed it to InfinityFree nameservers.
Then i added this new domain in the “Addon Domain” section.
I enabled CloudFlare for this domain directly from the “CloudFlare Manager” section.

Do i need to point the domain to CloudFlare nameservers to make it work correctly?
How can i completely eliminate my starting subdomain without deleting also the folder of the new domain in the file manager?

Thank you for your help and you time