Let's encrypt certificate shows Security warnings

I’m currently testing a website on infinity free hosting , and i have installed Let’s encrypt certificate and it works fine for some browsers ,but for others it shows " Your connection is not private" .

After searching the forum i found that the reason is :

That’s because our hosting does not support uploading CA chains, which fixes this error for most sites.
The way to fix this would be to upload a CA chain to your website. Unfortunately, that’s not supported on free hosting.

So is there any other free ssl certificate providers that i can use to fix this issue ?

If so please recommend some.


Use zerossl. It is next to let’s encrypt certificates on security and ssl page in infinityfree

thanks a lot for the info , but will it solve the security warnings on some browser ?

I don’t think using a different provider will help. A key feature to enable broad browser support is just missing from free hosting, and this affects all SSL vendors to some degree.

Using Cloudflare can help though.


Thanks for the reply ,

Can’t we just directly install it from the SSL page or I have to go through all these steps ?


You have to go through all these steps.

Please note that Cloudflare is itself not an SSL provider. Cloudflare provides a website proxy/caching/security/optimization service that just so happens to also generate SSL certificates to protect the connection between your visitors and Cloudflare, and their setup has better browser support than ours.

Cloudflare is a great way to get SSL on your site, but they are not an SSL provider.


Zero ssl works for me and never causes security issues. Let’s encrypt didn’t work for me either but zero ssl did

installed the Zero ssl ,but firefox still shows warnings on mobile phones.

Thanks for the reply ,

So the bottom line revoking the current certificate , and using the Security services provided by Cloudflare will solved all the warning issues (specially on mobile phones) ?

Do note that certificates do not take effect immediately either. So if it’s working on some but not all, maybe try waiting a day or two to see if the issue self-corrects


Hi and sorry to bother you guys again ,

i did setup Cloudflare account and followed all the steps and all looks fine on the Cloudflare account , and made SSL/TLS encryption mode Flexible and in the " Edge Certificates" they issued two certificates .

but here is the issue …

the Certificate is not yet applied and still using the old zerossl Certificate , anyway i went to “https://app.infinityfree.net” to the “free ssl Certificates” to delete zerossl Certificate ,but I couldn’t find any revoke button! maybe because it was installed today ? or am I having some issues ?

so i went to cPanel and delete the certificate manually and after sometime chrome read the new certificated which was issued by “Google Trust Services” ,but again at later time the chrome return to use the old zerossl Certificate for no reason .

So i think i messed up with a lot of things ,but why is this still not working ?

Now chrome is showing the cert again :

But Firefox still use the old one although cleared the cache on browser and did " Purge Cache" on cloudflare:


Try clearing your cache. After doing so, your certificate should be issued by Google Trust Services, Let’s Encrypt, or Cloudflare’s CA.


please see the update section in the reply .


It sounds like DNS cache to me.

When you switched your domain from our nameservers to Cloudflare, this involved a DNS change. But DNS results are heavily cache in multiple places along the route, so it may take up to 72 hours for the change to be visible everywhere. This isn’t something you or we can fix.


After two days , all the browsers except firefox desktop shows the new certificate and all the security warnings are gone .

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.