Issue with linking css file

When I am trying to update my css file at ftp.its showing updated contents in css file but on the site the webpage is working only with old css file content.

Even after deleting and reuploading both html and css file the issue pursues.

I solved it temporarly by adding css content inside html file with style tag but how to solve this permanently?

Is there any cache sort of thing?

Please help.

Please clear your browser cache then try again.
Or use a different device instead.


Adding to what Frank419 noted, please do not ping people as there are plenty of us here that can help you. However, this is free support so you must be patient.


Ok thanks.
I am new here will take care of this from now on

1 Like

Tried this both now.

But issue is still there all things are loading correctly except z-indexing. :frowning:

Are you sure that you have uploaded the file with the correct filename/path? Is your code loading the correct file?
And maybe, upgrade your os/browser. Z-indexing might not be working on old softwares.


my html as well as css file are inside htdocs folder so the path would be only “style.css” right without any extra path?

and for z-index support its fine.with my browser as i.have hosted on too its working fine there.

Please share the URL, as well as am image of what it is supposed to look like.




Then please share your url both here and on github so others can compare and better help you.


here is link for page hosted on infinity free :

this is the same site hosted on you can check the hyperlinks attached with github,telegram logo working) :

my files were stored inside htdocs folder.

1 Like

Nothing wrong to me

What are you getting? I suppose it was still some cache issue.

telegram,github button working?

check its not working on ijfinityfree hosted site

1 Like

Oh. That’s correct. These buttons aren’t working in infinity.
Weird enough…

I believe telegram is blocked on free hosting.
There is nothing you can do about it


Hm also came to this point after seeing this msg


False. InfinityFree does not modify the website frontend unless there is something which violates the ToS. the telegram API is blocked but linking to your telegram ID is not.

This is about making external websites making embed of your website, nothing related to the issue with clicking buttons.


Oh then what could be the issue
all css element loading fine.except links only

if problem should be of.linking style sheet then other element.should also not had.been.formatted.

and yes, when i am linking css directly into the html file by using style tag all links working fine.

1 Like

I can click on the links and it works fine for me. If anything, you can add the target="_blank" attribute to your <a> tags to see if they work while opening in a new tab.

The style.css file is missing but it should be irrelevant to what you face into.


It works well for me too

Maybe the OP expects that link to be opened in the telegram app (judging by the screenshot from the mobile phone)
and if so, then the problem is in his device/app


No now its working fine because i have added whole css inside html file using style tag.

the issue happens when i just link seperate css file to html using link tag.

Issue only happen that external link opening rest css objects import fine.

Leave its working fine as long i just use style tag