Installation failed: Abort class-pclzip.php : Missing zlib extensions

You might be receiving an error after attempting to install a plugin on Wordpress. The error could say the following. If one of these applies, feel free to read on.
Installation failed: Abort class-pclzip.php : Missing zlib extensions
or anything related to class-pclzip.php.

Note: not asking for support, yet just helping fellow people with an issue with their code. If you don’t find my tutorial helpful, you might want to start up your own topic and get professional support. I am an InfinityFree user, not an employee.

Why is this happening?
Recently, iFastNet has upgraded their PHP version for the free hosting plan. They have upgraded from PHP 7.3 to 7.4.8. You might want to create a backup with Softaculous App Installer (located in your InfinityFree cPanel) and reinstall Wordpress.

What if Softaculous is down?
You can create a backup using an alternative backup creator in your cPanel. Navigate to the top of your Control Panel/cPanel and click on “Backups.” You can create a new backup and reinstall Wordpress manually with FTP.

Alternative ways to fix:
Thanks to everyone who suggested an alternative way. Credits: KangJL, HaydenANG. Everything is quoted for full credit.

Moderators & Regulars: Please correct me ASAP if any information is incorrect so I can edit this message and update on the how-to.


I am also having the same error and unable to install any plugins on my site.
I tried re-installing from the wordpress updates page but that too failed with the above error.
Haven’t been able to try via Softaculous as this app is also down.

@fosters Then Unfortunately, You are going to have wait until the softaculous issues have gone. You may want to reinstall wordpress manually using the following guide;

As the FTP Servers appear to be working to standard.


Having the same issue. It was working fine until yesterday. How do I now install plugins and themes?

I’m not asking for support, this is a how to guide, but I’ll link your resources you’ve suggested.


Just need to upload updated plugins via ftp to the plugin directory. This shd take care of the issue

1 Like

I’ll add this in, thanks for suggesting an alternative way.

Yes, Apologies, I was suggesting an alternate way for @fosters , And i meant to reply to Him.


When i tried to manually install WooCommerce through the upload plugin in wp and i get this error, any help?
The uploaded file exceeds the upload_max_filesize directive in php.ini.

You need to split the file and manually upload it using ftp, there is a file limit of 10MB, So unzip the files locally, and manually upload them into the plugins folder

1 Like

Thank you so much brother

1 Like

Hi there, this problem is fixed as stated by staff

Hi there,

zlib and zip are added now please check again,

Thank you and stay safe !


After test installing a plugin, it looks like it’s still not fixed and still a big issue.

That means the file might be over 10MB. I read somewhere on the forums from Admin that it’s 10MB from my memory.

Try force installing plugins. Worked for me.

How to force install plugins:
First, go to > Manage the account you want > File manager > unpack locally into a folder > get to the plugins folder > upload folder with plugin contents inside. Hope this helped.


Thanks, man! I was facing this error while installing a theme. I tried uploading it’s folder this way and it worked like a charm! Thanks again! :slightly_smiling_face:

1 Like

No problem at all! Thanks for letting me know this worked for you!

1 Like

I am unable to Upload a theme in Wordpress, install plugins and update Wordpress to 5.4.2.
First two are really important for me. Is there any other old conventional way to upload a WP theme & install plugins?
I am getting Abort Class-pclzip.php : Missing Zlib Extensions

I have understood that it’s due to:

I just a need a solution to upload a WP theme & install plugins that’s all.

1 Like

Download the theme and plugin files. Upload the folders for the theme and the plugins to the respective folders under “wp-content”. I did this a few minutes ago and it works perfectly.


You’re welcome! I do have one thing to figure out still. The Site Health page mentions this “The required module, zlib, is not installed, or has been disabled.”. Is there any way to do something like installing this extension or enabling it manually? I feel it’s a dumb question coz that’s what this thread is all about. :sweat_smile:

1 Like