Image carousel not working

Hi there,

The image carousel under the “book now” button on my website - is not working. I am using elementor for this. I tried deactivating all of the plug-ins (except elementor) but still didn’t work.

Please help.


Mixed content

when you use HTTPS, then all resources should be called via that protocol, not via HTTP


how do i fix that? I have an SSL certificate, and a plugin for this - it is active.

I wrote you how above (read the article - use plugin mentioned there)

and use F12 (dev tools) from the browser to check the status.
after you correct it
also press CTRL + F5 during the check


Hi there,

Thanks for the response.

I have read the guide and had everything the guide suggested beforehand.

When I click f12, this is what I see

Is there any other way to fix this?


from the article !

also set dev tool (show all)


Yes, as I said, I already have the plug-in installed

then continue reading the article


I did

I tried everything

How did you manage to do everything so fast?

if it doesn’t work then open WordPress DB

and manually searches for these (everywhere)
that start with http and change it to https

make a backup DB just in case

and when you do it so that there is no more mixed content
We will see if the problem is somewhere else or if it will work (or use dev tools)


As you sent the article 20 mins ago lol

Is there an article on how to do that?

you can use the plugin (search plugin) from this article

or manual

I’m going to sleep now :joy:
someone else will be there to help you ( if necessary ).


Thank you lol

Anyway, for the next person that would like to help me, I installed the search and replace plugin, and followed the steps in the article sent.

The image carousel still doesn’t work.

Any help is appreciated.


1 Like

I followed the guide, replaced the HTTP URL with the HTTPS URL, regenerated the files, and the image carousel still doesn’t work.

I don’t think its a problem related to mixed content

No idea what you are talking about


or this?

You need to write clearly. What are you supposed to see??

1 Like

Start by clearing CloudFlare cache, then browser cache… what do you see?

1 Like

The image carousel - where you press the arrows on the left and right and a different image is supposed to show. It is under the button you circled.

Did that - still doesn’t work.

You were able to correct some previous (http) errors with the first-mentioned plugin

but you still have this via HTTP

maybe that address is configured in some file/s so they should be checked too
but I’m suspicious since you said you regenerated files