How to redirect my Infinityfree subdomain to my GoDaddy domain

I already have a subdomain here and I purchased a domain on GoDaddy.I have read this

is there a way to host a subdomain here and use GoDaddy as a domain? I need a clear instruction, I would really appreciate the help. thank

Switch the domain nameservers to and, add the domain to your account through the Addon Domains section in vPanel, then you can switch your nameservers back to what they were originally, but make sure you make an A record for each subdomain pointing to the IP displayed in the Client Area.

Let me know if you need any more help!


hello, I getting this kind of result on my domain ,

im not sure if I created the A record correctly

Well, you just need to add files.
It also appears that you created a record for @ pointing to our servers, which means that you’d also be hosting your main domain here.

1 Like

here I updated the A record and what do you mean I need to add files how will I do that? Do I need to reupload all the files from my subdomain to my custom domain, is that what you mean?

Can you share the URL of the custom domain and the subdomain?

And I think that other post in the beginning is confusing us. That article explains how to host a custom subdomain and not the 2nd level domain with us.

You seem to want to host the 2nd level domain and a free subdomain with us.


Hello, what I actually wanted is to use my custom domain not this one removedByMod. thank you

Here’s the link:


Note: Im on the process of uploading the htdocs to removedByMod/htdoc
am I in the correct path?

Yes, that’s correct.

Can you show all the DNS records you have configured for your domain?


Here, I just finished uploading the htdocs file, and when I click this [removedByMod) it redirects me to removedByMod, what is the next step for this?

  1. Delete the “www” CNAME record

  2. Add a “www” CNAME A record with the contents of

  3. Add a “@” CNAME A record with the contents of

  4. If you are using WordPress, change your site URL in wp settings.


it only allows url when I tried to add the IP this shows:

Sorry, my bad. Use an “A” record instead


Seems like the website is now working on custom domain now, but the problem is some of the images are not loading properly because of the link of the images are not updated is there way to fix this or should I do this manually?

Did you do this:


Yes that’s the reason why the custom domain is now working. but some of the images are broken

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.