How to add Cloudlfare SSL Certificate instead InfinityFree SSL?


I want to remove infinityfree free SSL certificate and add cloudflare instead. But even though I connected Cloudflare SSL successfully using your forum, It still shows the old SSL certificate.

I’ve tried reading all the forums and articles and still can’t remove the SSL certificate.

Other Information

(other information and details relevant to your question)

My guess is the problem is one of these two:

  • There is a configuration error on your domain. Either the domain is not using Cloudflare’s nameservers (or not using them exclusively - never mix nameservers), or the proxy is not enabled in Cloudflare’s DNS settings.
  • Everything is set up correctly, but you still need to wait for DNS caching. It can take up to 72 hours for your computer/network to realize that your domain is now being hosted by Cloudflare and send your traffic to Cloudflare instead of our servers. Basically what is described here: When will my domain name start working

If you want us to check if your domain is set up correctly, please tell us which domain name you’re trying to set up.


domain :

I did and checked everything you said…can you take a look at them and tell me what’s wrong? thank you

I have checked your site.

For starters, your SSL certificate seems fine. When I try to access it with cURL, I see that it’s using a certificate from Cloudflare. So your website is using the right nameservers and the Cloudflare proxy is enabled.

However, your website doesn’t seem to load at all when checked in a browser, and the response from Cloudflare says status code 520, which means “Webserver is returning an unknown error”.

When I check your website without Cloudflare and connect directly to the website IP (using hosts file overrides), your website is working.

So my guess is that your DNS settings in Cloudflare are not correct.

Please make sure that your settings in Cloudflare are set up as described in this article:

If that doesn’t solve your issue, please share a screenshot of the DNS records you have set in Cloudflare for your domain.


Ok, Thank you! I will check them now and here is a screenshot of the DNS records I have in my Cloudflare dashboard.

Please let me know if there any missing records on there and i will add them soon as possible.Appretiate your help. :hugs:

No issue


But for me, it’s showing as using an old SSL certificate. I also tried after clearing the cache. :thinking:

1 Like

The URL and certificate tell me that you are connected directly to our servers, and not to Cloudflare. Seeing how your DNS settings are all correct (pointing your domain to Cloudflare and Cloudflare to your website with us), the only possible explanation I can think of is DNS caching.


no worries.I removed the website from the hosting. Thanks. :hugs:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.