Help with SSL certificate

Username: Shermans
I cannot install an SSL Certificate. I would be grateful if someone could tell me what I am doing wrong. This is the first time that I have attempted to create an SSL certificate. I followed the instructions rigidly and slowly, and got as far as successfully receiving the Key and Certificate, including the Begin and End words. But try as hard as I can, I seem totally unable to install the certificate. I have tried uploading the Key first and then the Certificate (several times), so tried the other way round - Certificate first and Key second, which I did not expect to work and it did not ! I have backed up the Key and Certificate, so I still have it. But absolutely nothing has worked after trying for more than an hour. Does anyone have any clue what I may be doing wrong ?
The website is given above, and any help would be really appreciated.

Welcome @Shermans :slightly_smiling_face:

Check this thread Certificate Install Error ssl

There are two posts in that thread from Admin that may help you get the certificate installed, see below:

The SSL certificates UI in the control panel is not very intuitive. So please make sure to follow the instructions exactly as provided here:

InfinityFree Knowledge Base

How to install an SSL certificate

In order to get a padlock in the address bar in your website, you need to install an SSL certificate on your account. This article describes how to do that.

So paste the key, click Upload Key, paste the certificate, click Upload Certificate, exactly in that order. Any other order won’t work.

Second post:


Again, the steps are:

  1. Paste key.
  2. Click Upload Key.
  3. Paste certificate.
  4. Click Upload Certificate.

Don’t paste both at once and click the Upload Certificate button. Don’t paste some field and then leave the page. Follow the exact steps as described and it should work.


I just tried to upload your certificate and it worked fine for me.

What did you actually see? You say nothing has worked, but what do you see? Do you see any error messages?

Thank you all for your advice and recommendations. The problem is that when I go to my website in Google Chrome, the address field says “Not secure” still. I keep clearing the cache to make sure it is not just inherited. So there is no padlock. As far as I can understand it therefore, the SSL certificate has not uploaded / installed. I am obviously doing something wrong.
I am really grateful for the helpful comments.

Well, I have tried again and unfortunately made no progress. Still no padlock.
I have been very careful to follow your instructions :

  1. Paste key.
  2. Click Upload Key.
  3. Paste certificate.
  4. Click Upload Certificate.

When I click “Upload Key”, the hourglass shows for about half a minute and then then returns to where I was. So I scroll down to the certificate which by then has always disappeared. So I paste it back in, I click on “Upload Certificate” but then nothing happens except that the screen refreshes and I am back where I started.

I cannot see what I am doing wrong. I am assuming that the Certificate should by then be installed and would expect to see the padlock. But I do not; I just see “Not Secure”. I makes no difference if I use Chrome or Microsoft Edge; always the same “Not secure”. It is so frustrating, but it is obviously my fault, and I am not doing something properly.

Can I delete the Certificate and then start from scratch, and create a new Key and a new Certificate because I fear that I have tried to do this so often, that I may have confused the system ?

Sorry, I am back again.
I just entered my website into the SSL Checker on the Infinity website and got this result :

“Resolves to
Server Type: nginx
The certificate will expire in 89 days.
The hostname is correctly listed in the certificate.
The certificate is not trusted in all web browsers. You may need to install an Intermediate/chain certificate to link it to a trusted root certificate. Learn more about this error. The fastest way to fix this problem is to contact your SSL provider.
Valid from December 3, 2020 to March 4, 2021
Serial Number: 37a85ebc563a50943229afcbb4f43050
Signature Algorithm: sha256WithRSAEncryption
Issuer: GoGetSSL RSA DV CA”

So that suggests that the Certificate is not recognised by either Chrome or Microsoft Edge. Do I understand that correctly ?

SSL is installed, you just need to force it.



Thank you so much. I am a silly fool.

The problem was that every time I tried to test my website, I simply clicked an existing short-cut on my desktop. Of course, I had completely forgotten that the short-cut began with http://. So all this time, I have been loading an insecure short-cut. Your reply made me think, and I am so grateful to you - however, it makes me look like an absolute idiot.

The only consolation is that it is a grey, wet day outside, and so I have not been missing out on the Dorset countryside while agonising over this problem.

Thank you so much again.


No one is an idiot until they think that they know everything.

Glad that you got the problem solved


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.