GoGetSSL certified, but Softaculous says "Cannot find trustworthy SSL Certificate"

Username (e.g. epiz_XXX) or Website URL


Error Message

Cannot find trustworthy SSL Certificate.

Other Information

The first thing I did with my website, is get a GoGetSSL certificate, which in cPanel, have uploaded in the SSL/TSS menu, Private Key to the Private Key field, and Certificate to the Certificate field. (The start and end tags are also there).

However, now I want to use and install CakePHP with Softaculous, because it’s a good framework, and under “Choose installation URL”, when I wanted to select my website, and changed the default http to https protocoll, the auto checker said “Cannot find trustworthy SSL Certificate”.

I would love if you could help me out with this issue, because I don’t want to use HTTP, because I presume it would not actually work, and I have no clue as to why it says that.

Thank you in advance. :slight_smile:

Just use HTTP, it should work fine, as the SSL certificate is for browsers anyway.


I have had the same problem with a plug-in for Wordpress called JetPack. When I installed and ran it, it told my certificate was invalid even though I used the infinityFree cert. I would solve the problem in two ways. Either get letsencrypt OR (what I did) use cloud flare with your website. I’ve noticed that some apps that you may use for your website have trouble identifying the origin of the cert that was issued by infinity free. I suggest using cloud flare because when I changed the name servers and activated it (DONT USE CPANEL CLOUDFLARE), jetpack worked normally! I hope this helps!


You are correct, but depending on your use of the website, you might not get higher priority in SEO rankings and if you have customers, you might have more trust issues (many customers think that non-private sites are dangerous). Google chrome also sometimes tells if your site is unsafe to users with the big red warning sign that covers the whole site.

Thanks for the reply @Casmat .
Now I have never used cloudflare, and I have no idea what exactly the cloudflare switch does that you can find here on infinity cpanel.

So if I understood correctly what you wrote, you are suggesting just simply changing the nameservers to cloudflare servers, and that hopefully should solve the issue? Won’t I gonna have to reapply for a certificate if I change the name servers? And if so, how is changing name servers gonna change the certificate validation, if I get it from the same GoGetSSL?

I’d love it if you could clear this up for me :slight_smile:

EDIT: Alright, since you wrote not to use the infinityfree cpanel cloudflare, I registered a cloudflare account, but when I try and add my website there, it says no subdomains allowed, and that is what you get for free. Any idea for that?

You need a custom domain. Follow this guide…

1 Like

Meaning, cloudflare won’t solve my original issue, that is, being unable to use cakePhP in https. Right?

It shd solved ur issue, provided u r using custom domain…

Well I am not. I use a free subdomain that I registered here on inifinity.

Live with it then

What is the website you are trying to use? Tell me the URL.


When you add a website to cloudflare, it says no subdomains? @Admin Are infinityfree domains subdomains? I think cloudflare recognizes your domain as a subdomain. myviphub.rf.da - The rf in this URL might be recognized as the actual domain. The .da might be recognized as the actual ending for a domain (.com, .org, etc.)

In my understanding, I think cloudflare takes rf.da as the actual domain name and the myviphub as the subdomain name.

I think the options are the following:
(PAID) Upgrade cloudflare plan
(FREE & RECOMMENDED) get a domain at freenom

Yes and no.

  1. Cloudflare CANNOT be used on free subdomains from InfinityFree
  2. You CAN use Cloudflare on Custom Domains (yoursite.com) and with Custom Sub-Domains (subdomain.yoursite.com)

I presume it is owned by infinityfree.
I don’t know, when I registered my free account here on infinity, I chose this free domain.

You need to set Cloudflare up with your main domain first, and add the sub-domain afterwards.

isnt rf.gd a domain though? (made by InfinityFree?) and then when you register an ifinityfree ‘domain’ its actually a subdomain on rf.gd?

It is, but it’s from Infinity Free, so you cannot change name servers, therefore, it cannot be used with Cloudflare.

1 Like

I presume it is owned by infinityfree.
I don’t know, when I registered my free account here on infinity, I chose this free domain.

Than you cannot use cloudflare