Gateway Timeout

Website URL

(I cant Upload Persta Theme the theme is 9.8MB)

Error Message

(Gateway Timeout)

Other Information

(I cant anyway upload theme in my persta shop)

@AEM-Bearings I didn’t use Presta Shop before but try opening the ftp, locating the presta shop installation and add manually the folder/files of the theme in the themes folder and activating it by admin panel (presta shop’s).

Hope that this helps you :slight_smile:


Try to first extract the zip in your computer, create a new folder in themes folder with the name of your theme and then uploading the files inside it.

This was also an issue with someone else, @Admin the MFTP error has happened again, someone got to the end of the upload and it gave the same error, What filemanager are you using, or @AEM-Bearings

What can i do now?

Please create a new topic for your problem so that we could help you out.

If you are not manually able to upload theme files then you can follow my steps to upload.
First extract your presta theme “.zip” file on your PC and then first compressed 5 MB files into one file and then again compress remaining 5 MB files.
Then open your presta shop and create a folder with theme name and then open it.
Then upload & extract both compressed “.zip” files.
Just a little trick to upload large theme files.

I see more complaints about the “MFTP error” issue. Unfortunately, I haven’t been able to reproduce it yet, which makes it hard for me to figure out what’s going on.

Could someone who gets this issue try to answer some of these questions:

  • What does the Network tab in your browser’s developer tools show? What is the HTTP status code and what does the response say?
  • Do you get this with files of all types and sizes or only specific ones?
  • Do you get this issue on all hosting accounts or only some?

Yes, MonstaFTP Is outdated, see the below callback made throughout the MFTP Session; (301 error - moved)

Indicating that the FTP Server is version 2.9.1, however if you follow the url, it tells you how the latest version is 2.10.1, which has many bug fixes and adds a right click function to create zip archive,
Of which our MFTP doesn’t, and many new features are not available on our ftp;

However my MonstaFTP Makes a similar call back, but the url is;
ALong with the fact that on my MonstaFTP i can create zip archives from the right click menu, however cannot, meaning mine is version 2.10.1 (With the Archive update), the latest, however InfinityFree’s is not!

Note the ?v= in the URL standing for version, then the OS and token

Hence MFTP is about 3 versions behind the current!

Following @MAHOfficial issue with unziping and ziping files, that is fixed in the 2.10.1 update :slight_smile:

However The is actually up-to-date, with the following callback;
Showing ?v-2.10.1, indicating that is the newest, compared to the Vpanel manager, as exolained above.

Do I have any issues?

Sorry, Didn’t read it properly, i was saying how wrckrlph had an issue with uploading, which is solved (ish) in 2.10.1

1 Like

ok :smiley:

You’re right about the version difference. However, there were also issues with the uploader of MonstaFTP 2.10.1. Between those versions, they changed the upload system to upload in chunks, which may help to alleviate this issue. But the chunked uploader also caused many other issues, especially with various File Not Found errors.

Nevertheless, anyone having the “MFTP error” issue can try the installation on I’m curious to hear how well it works for everyone!


Ahhh Ok, I noticed that on the changes page, So far it works well!, But would the version difference on do anything?, Or did they leave it on 2.9.1 for a reason to avoid chunk uploads?

I don’t know why iFastNet hasn’t updated their installation. However, given how the chunked uploader had issues, I was glad they didn’t.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.