Ftp not allowing me to add directory


(please specify the website or account you are asking about)


(please share the FULL error message you see)

550 Can’t create directory: Permission denied

(other information and details relevant to your question)

Update the CHMOD permission folder where you want to edit or create a directory. Make it writable or readable on public/owner.

done that and still get the same response
550 Can’t create directory: Permission denied

So where are you trying to create a directory? Make sure you are trying to create one inside the htdocs folder.


What do you mean cannot create a directory? Where do you get? From Online File Manager or FTP? Screenshots please? Thank you!

Outside htdocs, there’s a file named DO NOT UPLOAD YOUR FILES HERE.
Listen to what it says and upload inside htdocs folder.

1 Like

![monsta nwfil|690x387] and i’m not uploading in the main file system i’m trying to create a new directory for my ssl http verification

Like I said DO NOT UPLOAD YOUR FILES THERE . upload inside htdocs.

And why not using our own SSL tool? it’s quite easy to setup.


You have two htdocs folder, but just upload your every file inside sbrlive.co.uk > htdocs.

And why your sbrlive,co,uk redirected to epizy,com subdomain?

You should use https://app.infinityfree.net/acmeDomains to set your ssl up. :slight_smile:

1 Like

I feel you. You want to verify your DOMAIN CONTROL VALIDATION. But sadly, InfinityFree blocks the bots that will read your verification files even though you do it properly.

You can still create that folder in /htdocs. Meaning:

…/htdocs/.well-known/ :white_check_mark:
http://example.com/.well-known/ :white_check_mark:
and not this
…/.well-known/ :no_entry_sign:

But just like I said its no effect. Still you can create it on your accounts’ panel (the InfinityFree’s Official SSL certificate tool).

that was my first port of call but still not got it it to work hence why i had to go down a different route i’ve been trying to sort this for days if i had any hair it would be pulled out by now

Read this:

Adding CNAME records on your vistapanel domain will verify your domain dns status and get a free ssl.


Or you can use the manual creation of SSL using Let’s Encrypt and OpenSSL commands.

Website Tool: https://gethttpsforfree.com/

Note: HIGHLY RECOMMENDED. BUT VERY DIFFICULT. If you are too determined(just like me), use that website.

right im off to bounce my head off a brick wall 3 days ive been trying to get this to work ive read the infinity free knowledge base i did that first time with no success

Ok last try could somebody tell whats wrong out of this lot then i might get somewhere