FTP Don't Work


try setting the port to 21
recheck the data with details from control panel or use the file manager button in control panel

Replace ftpupload.net with ftp.epizy.com


yes, like @KangJL said replace the same. Also if it still doesn’t work, use the file manager button in control panel

Don’t use that. It almost never works right. Try as @KangJL said, that almost always solves the issue.

Doesn’t ftp.epizy.com redirect to ftpupload.net?

Yes, but I think something on the DNS side of things gets messed up. Somehow one works, and occasionally the other doesn’t. Admin might know more.

I wish I did.

All I know is that a remarkably high number of people are having trouble with the ftpupload.net hostname. As far as I can tell, the hostname itself is working fine, but the domain is blocked by various virus scanners and security filters. If you use a VPN, you can usually bypass those and see that the hostname itself worked.

Who has actually blocked this domain name and why is not clear to me. I also don’t know if they blocked the domain because they somehow got the idea that our hosting is dangerous, or just because the domain had a bad history before we got it.

I don’t know who to ask or how to ask them, whether this is something we can do something about or whether this is just a big misunderstanding.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.