Filezilla FTP stuck at Initialising TLS

(http://kassborra.free.nf/index.html)

Hi, Everything was working fine yesterday, could upload files no prob.

Today, everytime I try to to upload using Filezilla it keeps getting stuck at:

Initialising TLS

After a while it just gives a time-out message.

Any help would be great!

Can you share the full error logs from that top panel in FileZilla?

4 Likes
Status: Resolving address of ftpupload.net
Status: Connecting to [64:ff9b::b91b:860b]:21…
Status: Connection established, waiting for welcome message…
Status: Initializing TLS…
Error: Connection timed out after 40 seconds of inactivity
Error: Could not connect to server
Status: Waiting to retry…
Status: Resolving address of ftpupload.net
Status: Connecting to [64:ff9b::b91b:860b]:21…
Status: Connection established, waiting for welcome message…
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 638 of 6900 allowed.
Response: 220-Local time is now 08:46. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220 You will be disconnected after 60 seconds of inactivity.
Command: AUTH TLS
Response: 234 AUTH TLS OK.
Status: Initializing TLS…
Error: Connection timed out after 40 seconds of inactivity
Error: Could not connect to server

Never seen all this stuff before!!!

I’ve just noticed the address ftpupload.net which is incorrect.

Don’t know how that got altered.

I’ve changed it back to ftp.infinityfree.com but it still gets stuck at TLS

Very weird??

Please read this thread

5 Likes

Exactly the same problem I’ve been having.

Hopefully Moderator Greenreader9 will be able to sort it out.

So does the solution proposed in that topic work for you?

We cannot solve this issue for you right now. Our FTP server only supports IPv4, and your connection does not use IPv4. Your ISP runs a translation proxy in between that mucks up the connection. We cannot just “sort that out”.

6 Likes

Try using a different network (Like a mobile hotspot if you have enough data, or an Internet cafe). A VPN connection may work as well.

8 Likes

Unfortunately, I do not use VPN.

I will contact my ISP and ZTE (the maker of my mobile MC888 router check if the router is causing the “IPv4” problem.

If you are going to contact anyone, I recommend to contact your ISP. Most likely, they are running an IPv6 only network, and they are the ones operating the IPv6-to-IPv4 gateway that’s probably the reason your FTP connection gets messed up.

I doubt any router would go into IPv6 only mode unless the upstream network is IPv6 only.

7 Likes

Thank you to you, @Admin. I will contact my ISP.

Firstly, let me say thanks for all the help. Here is what I’ve done.

I’m not technically minded and I haven’t got a clue about IvP4/6 etc. What baffles me is that it has worked perfectly for months, using Filezilla to log onto infinityfree, and upload files to my account. Then yesterday, the stuck at TLS… problem. Same internet provider, same router (ZTE), same computer, no changes to any settings at all.

I also have another free hosting account which I don’t use very much, but Filezilla will quite happily log onto that account with no problems. You can perhaps understand why I’m perplexed.

The only way I can connect to infinityfree using Filezilla now, is to set up my mobile phone as a hotspot and it seems to work fine. Luckily, I don’t have a vast amount of Mb to transfer, so it’s within the data allowance of my mobile package.

I just wish I didn’t have to resort to these methods. Works fine for months, then kaput.

Thanks everyone.

Just to double check: @HTaylor and @MarmiteTheCat are different people, right?

I say this because the problem description is so extremely similar: same FTP connection issue, same ISP (Three UK), same modem/router brand (ZTE), and similarly both not having access to a VPN.

The other explanation is that Three changed something that caused this issue, and they always send ZTE routers to customers.

Nothing suspicious here, but just want to double check.

Just to be clear: I assume you’re talking about another hosting account with us? Not another provider? If it is at another provider, would you mind sharing the FTP hostname?

That’s indeed very strange.

In the logs, we can see that the FTP connection gets stuck when trying to setup TLS, which encrypts the connection. Of course, the connection encryption needs to be set up before any credentials are sent, so the credentials are not sent unencrypted.

Which also means that there cannot be any possible way at all for the FTP TLS to work for one account but not for another: the connection breaks before any account specific information is sent.

Given that you’re both on the same ISP, my best guess at this time is that Three changed something that caused the FTP connection to break.

4 Likes

Hi.
I can assure you that I have no connection to @H Taylor.

Your observation about the similarities between our problems and the equipment is valid.

What setting would Three arbitrarily make that would cause this problem.

Is there any router setting I could change that might overcome it, bearing in mind my lack of technical prowess?

Thanks.

Sorry, just seen the part about the other host provider.

The other account is not with you, but the host name I use (according to Filezilla site manager) is files.000webhost.com

I’ve just now tried the above out and Filezilla connects no problem.

Very strange indeed!

Thank you, @MarmiteTheCat, for your comprehensive note of the situation.

Your experience match mine and your summarising sound.

Yes, @MarmiteTheCat, it would help if anyone knows of specific routet settings that could be explored.

For Information
—----------------------
Just as @MarmiteTheCat, I am able to FTP-connect to another server – but NOT to the Infinityfree (IF) server.

Without success, I have tried connecting to IF via ‘ftpupload.net’ and via ‘ftp.epizy.com’.

I assume you are in the UK and on the Three network as well.

With both of us having the same problem, I’m sure Admin will get to the bottom of it.

Regards.

Yes, @MarmiteTheCat, I am in UK – in Birmingham.

Kind regards,
HT.

To help you better understand the issue, here is a bit of a primer about IPv4 and IPv6 and translating between them:

IPv4 and IPv6 are basically two different ways to do internet. IPv4 is older and generally more widely used, but the newer IPv6 is becoming more popular every year due, largely out of necessity due to scalability issues of IPv4. Still, software support and experience is typically lagging behind for IPv6.

The problem with IPv4 and IPv6 is that they are incompatible. If you have an IPv6 connection, you can only talk to other computers on IPv6, and the same is true for IPv4. For this reason, many systems support both IPv4 and IPv6 so they can connect to services using either protocol.

However, your internet connection only supports IPv6, not IPv4. But our hosting platform only supports IPv4, not IPv6. So they cannot talk directly. This creates a bit of a problem.

Your ISP, Three, knows that many sites and services don’t support IPv6 yet. So they have setup a big router somewhere centrally, and all traffic that’s supposed to go to an IPv4 destination from their IPv6 customers is sent there. Using that router, Three can forward the IPv6 connection to your home to an IPv4 connection to our servers.

But any time network translation needs to happen (like switching between IPv4 and IPv6), there is the chance for things to get mangled, mislabeled or lost. And it would seem that Three did something in their big router that causes your FTP connection to get messed up.

I don’t know. I’m pretty sure that it’s related to their IPv6-to-IPv4 gateway. But I’m not an internet provider, so my knowledge about the subject is limited to that such gateways exists and what their purpose is. I have no idea how you would set something like that up, let alone how to avoid this specific issue.

I doubt that. The IPv6-to-IPv4 translation is done somewhere at Three. And they most likely just don’t provide IPv4 connectivity to your home, so there is nothing that can be done on the router side.

The FTP server from 000webhost.com appears to support IPv6 natively. So you can just connect to it over IPv6, and avoid the network translation.

8 Likes

Wow. I think I understand what you’re saying.

Just gotta hope Three sort their auto-switcher thingy out.

Just another observation. I’ve been poking around in the router settings using the browser interface, and it’s set to auto-reboot at 03:00am every Tuesday. This is the default factory setting and I’ve left it alone.

It seems a coincidence that the TLS… stuck problem first appeared later the same morning. I’ve had the router for almost a year, so it’s obviously been re-booting every Tuesday ever since.

I’ve done a manual reboot, but to no effect.

I can get past the problem using my mobile phone as a hotspot whenever I need to upload files. Luckily, the whole site weighs in at less than 300Mb, so maintenance won’t be an issue as I’ve got 10Gb per month allowance. (O2 network, so not all eggs in the same basket!)

Fingers crossed it magically sorts itself out.

Thank you for all your time spent on this matter.

Kind regards,
Kev