Error with rank math sitemap -Unable to verify the first certificate -sitemap url

Error Message

Unable to verify the first certificate. in

i just submitted my sitemap(made my rankmath) to google search console and it returned a error ‘couldn’t fetch’ so i contacted rankmath forum with the same error and they returned with this!
Your site and your sitemap altogether return an error code Unable to verify the first certificate.. It is likely an issue withing your site or your host. :

Please fix this and let us know if the issue persists even when your site returns a 200 OK Status. You can use this tool to check this " (the above link under error message)
i got my ssl certificate through lets encrypt from infinity free but still i face this error


Ur WP has crashed.


crash has been fixed

any help?

Still the same.

Hv u tried adding ur domain to ?

sorry it actually had a conflict with a theme…website is up now

This is probably caused by the lack of a CA chain with our SSL certificates, which are unfortunately not supported on free hosting. I believe Google works just fine without it, but third party validation tools may be less advanced.

You can probably just ignore this issue and your website will work fine. If you want to fix this, you could choose to use Cloudflare or consider switching to premium hosting.


thank you for the solution can you please provide me with steps I mean how to migrate from a free SSL certificate(current one) to Cloudflare

  1. Delete the current SSL certificate from your account.
  2. Sign up to and add your domain there.
  3. Change the nameservers to the ones provided by Cloudflare.
  4. Wait 24-72 hours for DNS propagation and Cloudflare to setup the SSL.
  5. Configure Cloudflare and WordPress like described in this article: How to make Cloudflare Flexible SSL work with WordPress - Docs - InfinityFree Forum

thank you for the response
I have deleted my certificate
Deleted my SSL/tls
removed all cname records
but still, I see my certificate is valid on my website
(Signed up for Cloudflare too but the account is still not activated(Cloudflare still didn’t detect a change in nameserver records)

That’s because you are still using infinityfree nameservers.

You shd use CF nameservers

I have changed the nameserver to that of Cloudflare

Its almost been a day till now but still its showing infinity free nameserver
Did I take any wrong step?

Did you login to CF to “submit” this info?

yes i submitted…24hrs ago

You have to wait then…

Thank you for your support!
I finally got my certificate from Cloudflare
My website is working fine now

I am using WordPress
should I change my Cloudflare settings now?

Yup, you have to change

Just changed my settings and i get

This page isn’t working

Could you please share the full error message? Every browser provides additional information as to why the site is not working.