Error establishing a database connection


Username: epiz_31488476

Just signed up recently to InfinityFree and created my website on it. So have been busy editing the site in wp-admin and then refreshing the site to see the changes.

On a daily basis, I’ll have frequent errors stating:

Error Establishing a Database Connection

This error message is on both the wp-admin page and/or the web pages themselves. For example, I’ll make an edit and update/publish from wp-admin and the update/publish button just spins and then if I refresh, I get the above error message. Or I’m just browsing the web pages and I’ll get the same error message.

This can happen any time during the day or night and can happen multiple times per day. Usually, it takes anywhere from seconds to minutes before refreshing the page brings it back online.

I’ve seen similar posts on the forum with the same error and it seems to the InfinityFree servers can be very busy. I understand this is a free account with the occasional glitches but given the advertised 99.9% uptime, these glitches are happening too often.

Just wondering if I’m expecting too much for a free account?



Username: epiz_31461850

Created a sub-domain recently and have been editing the web site in wp-admin. After a few days, I got the error message:

Error establishing a database connection

Went into control panel and the database has gone missing:

MySQL Databases: 0 / Unlimited

Plus the domain information is wrong as well:

Sub-Domains: 0 / Unlimited
Add-on Domains: 1 / Unlimited

There should be 1 sub-domain and 0 add-on domains.

I’ve seen similar posts of databases going missing in other people’s accounts and had to be recovered. I may or may not be in the same boat.

Can you advise what has happened to my account?


As you can see in the banner topic:

Missing Databases

The issues with SQL102 and SQL103 have been solved now as best as possible. The missing databases have been restored and sites using this database server should work again!

The issue was caused by a system issue causing some data to be sent to the wrong server. Most of this has been corrected now, but there may be a small number of users for which the data is still located on the wrong server.

If you had a database and it disappeared, please send a ticket to iFastNet at so they can migrate your data to the right server.

Please see this topic to learn more .

1 Like


I’ve raise a ticket with iFastNet as the database is still missing for Username: epiz_31461850.


Got my database back for epiz_31461850 and the website is online again.

But noticed on cpanel its still showing 1 add-on domain instead of sub-domain:

Sub-Domains: 0 / Unlimited
Add-on Domains: 1 / Unlimited

Can you advise?


And I suspect the anomaly with the sub-domain/add-on domain is causing my issue with verifying the ZeroSSL certificate I created for the sub-domain. It keeps saying “no cname found” even though I’ve already created the cname.

FYI - this is for epiz_31461850.


Are you creating ssl certificate from zerossl website or using the client area ssl tool? generating from will not work because of the security system.

Yes, I created the certificate from the client area ssl tool. Looks like I had to wait quite a while before I could verify the ZeroSSL certificate.

For those who intend to use ZeroSSL, take note the certificate generated includes an intermediate and root certificate. The root certificate is by “USERTrust RSA Certification Authority” and should already be in your computer’s certificate store.

But my computer’s certificate store did not have the intermediate certificate which is by “ZeroSSL RSA Domain Secure Site CA”. Without it, your website’s certificate by ZeroSSL cannot be verified.

You need to install the intermediate certificate in your certificate store before it’ll work on your computer.


If the domain names on your account work, then don’t worry about which list has the domain name.

Like it says on the page: it can take up to 24 hours.

This shouldn’t be necessary. Most modern browsers should be able to detect that your domain’s certificate is ultimately signed by USERTrust, and access your domain without additional configuration.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.