Error 502 - Bad Gateway


epiz_25752217 —

Error Message

Error 502 - Bad Gateway - Host Error

Other Information

I know the homepage worked about 4 months ago. This seems to be the case for quite a while now, but it just came to my attention. I have done some research here in the forum but did not find any specific advice on how to fix it. Can I try myself? Is it a problem from InfinityFree? Appreciate any help!

This is what I see

Did you follow this guide??


A post was split to a new topic: Website Error

Appreciate the response and I think i got closer to understanding my problem. I have set it up quite a while ago so I can’t really recall if I used this guide.

But I was running throught the steps in the guide (cloudflare was already set up). At step 6) i was running into a problem. In the cloudflare DNS it says:
“Your DNS zone file is hosted by Byethost, a Cloudflare partner. Manage your DNS records at their website.”

I never did anything on Byethost - why is it appearing in my Cloudflare account? I guess my problem is that I do not really know my Cloudflare nameserver?

ByetHost is the company that manages your InfinityFree hosting account.

Can you screenshot your Cloudflare DNS records?


This is annoying. It seems your domain name is using the legacy Cloudflare integration, which has been removed from the service some time ago.

I think the fastest way to resolve this is to just remove the domain from your account and add it again. That should recreate all the settings and link your domain name directly to our servers.

After that, you can sign up with Cloudflare yourself and add the domain if you want to keep using Cloudflare.


I’ve just tried deleting and adding again my domain and now unfortunately get “Directory Listing” in my homepage. Any suggestions how I can get rid of this?

After some research I have already tried:

  1. Deleting the index2.html in my htdocs folder (there is still an index.php)
  2. I’ve added “Options -Indexes” into my htaccess file within htdocs

Both unfortunately did not help. Any other suggestions what I could do?

Make sure you are uploading the files to the correct directory, a new one may have been created.


Indeed there was a new folder created when I have newly added the domain:

So I went into this new folder and added all data from my previous htdocs into the htdocs folder within

The error message I get now when opening my side is:

So the error message is looking different after I have performed above activity. Any ideas what could be causing this new “502 Bad Gateway” message?
I was previously using SSL through Cloudflare, might this be the cause why it has not automatically updated and do I maybe have to change anything in Cloudflare?

I’m not sure what exactly is causing this error, but I can tell it has something to do with your WordPress code.

Because loading in the WordPress readme file works fine:

And if I try to open wp-admin, I get redirected to HTTPS and then can’t continue because there is no SSL certificate installed on the site.

I’m not quite sure how this could happen, but maybe getting access to the wp-admin interface will reveal more clues.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.