Username: epiz_27868068
Website/domain: with info and images subdomain

I opened my website, then I suddenly got this.

I know this is a very common problem, and I saw a lot of this problem on InfinityFree forums. I don’t have much time to read those and I don’t understand it. It would take a while to fix this problem without knowing how does this problem works alongside troubleshooting. I hope somebody helps me

More info (just-in-case someone needs these):
I use Cloudflare

with Always Use HTTPS on

.htaccess file

ErrorDocument 400
ErrorDocument 401
ErrorDocument 403
ErrorDocument 404
ErrorDocument 503
RewriteEngine on
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URL} [L,R=301]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME}\.html -f
RewriteRule ^(.*)$ $1.html [NC,L]

DNS Records

;; A Records 1 IN A 1 IN A 1 IN A 1 IN A

;; CNAME Records 1 IN CNAME

;; MX Records 1 IN MX 0 1 IN MX 10 1 IN MX 20


I also purge cache my website several times on CF


You better read…

Make sure your Cloudflare settings are clean

If you’ve just enabled Cloudflare, all the Cloudflare settings should be standard, which is good.

If you’ve already tinkered with the Cloudflare settings before trying to get HTTPS to work, here are some settings to verify:

  • In the SSL/TLS → Overview tab, Encryption Mode is set to “Flexible”.
  • In the SSL/TLS → Edge Certificates tab, the setting “Always Use HTTPS” is set to Off.
  • In the SSL/TLS → Edge Certificates tab, the setting “Automatic HTTPS Rewrites” is set to Off.
1 Like

You can refer to this for more info…


Thank you for your response.
I’ve been using CF for a week. I never occurred this problem until now, then I got this.
I don’t use wordpress

Maybe this line is a culprit:

RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URL} [L,R=301]

Try to remove it and leave “Always Use HTTPS” intact, as Cloudflare redirects to HTTPS your website for you.


I’ll try

Thank You.
My problem was fixed.
I changed


But my is different from, but they are literally the same thing.
For instance, when you enter it is still there, even though I removed it.

I also turned this off

so first
you need to pick one - https:// in htaccess in cloudflare
2nd - set cloudflare ssl to Full
3rd - purge cache (cloudflare and on ur pc)

This rule doesn’t work when using Flexible SSL. Try this one instead:

RewriteCond %{HTTP:X-Forwarded-Proto} =http
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

I want to stay with Flexible SSL. So I will do this

instead of this?

The .htaccess snippet I shared works both with Flexible SSL and Full SSL. Using Full SSL is more secure but takes a bit more effort to set up.

Ok, thanks :grin:

4 posts were split to a new topic: Too many redirects

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.