ERR_SSL_PROTOCOL_ERROR after uploading cerificates


I am trying to activate SSL on

But I keep getting

I did follow all the steps to verify CName records, generated certificate and key and uploaded both of them to the SSL section of cpanel.

Please any help would be appritated.
(other information and details relevant to your question)

The status of the ssl certificate in the client area is : No SSL certificate was found

You did not.

Please screenshot TLS/SSL section from the VPanel

Thanks for the reply!!!
Attaching SS

I have left the CSR section blank

Strange indeed. You may have to wait for Admin…

Yeah! But thanks anyways! Last night i tried using Let’s Encrypt and had the same issue today i tried again using GoGetSSL and i am still having same problem.

You can also use CloudFlare…

1 Like

Thank you so much for the help! I will wait for an admin for sometime and then try it out! Thanks

worked like a charm :). Thanks!!


Hello @Gaurav11, I am glad you got your issue fixed. Note that it is usually easier to use LetsEncript for free SSL here, it is generally faster and with fewer errors. (Just a note for the future)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.