DNS not propagated even after 3 days

My website URL is:


What I’m seeing is:

I’m using this software:

Additional information:

My site is myebizventures.com.
Even after 3 days of updating my infinityFree name servers, I am seeing only the attached error message when I try to load my site.
When I try myebizventures.com/wp-admin, I see the same result.
Please lemme know the issue here.


Your site works fine to me. You should try to flush your DNS cache.

About your wp-admin see:


Thanks for the response. I flushed the dns once yesterday but no use.
Again flushed now. Let’s see if it works.
But the site opens on my mobile. But not on my laptop.
On the wp-admin, I couldn’t access my site at all. So don’t know how to disable HTTPS.
Any help on this is appreciated.


To disable HTTPS, change the site and WordPress URLs to their HTTP version via your database’s phpMyAdmin by following this guide.

1 Like


Have you tried to use another browser or visit your site with www?

1 Like

Yes. I can see when I try with www, the site opens.
When I use a different browser, the site opens with or without www!
But how can I make it open without www on my chrome browser?

Try clear your cache. if that doesn’t work, try to Re-install it.

wp-admin works fine now after changing the HTTPS to HTTP.
I used this video tutorial to change it. May be useful to many others.

Thanks a lot BayoDino for the guidance.
Hopefully this HTTPS issue will be resolved soon.
Have a great day.


Facing another issue now :frowning:
Please try to access myebizventures dot com & myebizventures dot com/wp-admin
Some technical difficulties.
Please help.

is seems that u break ur wp files.

have you tried or upgrading?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.