Deprecated create dynamic data

Website URL

Error Message

Deprecated create dynamic data… My code run OK from various months, and now?¿?¿?

Other Information

First there were problems with the IP and that is why the service was suspended. Now I find that my code that previously worked perfectly cannot dynamically create the reading of my SQL DB, they have changed the host name and now part of the code is deprecated. What is happening? How and when are they going to fix this?

1 Like

I’m also facing the exact same error since today. The CodeIgniter based site was working flawlessly until today when it fails citing dynamic data creation problem. Was the underlying PHP version suddenly bumped up? What went wrong here?

A PHP Error was encountered
Severity: 8192

Message: Creation of dynamic property CI_URI::$config is deprecated

Filename: core/URI.php

Line Number: 101


File: /home/vol9_2/
Line: 316
Function: require_once
1 Like

I don’t know what happened but the problem is with infinityfree, or they have changed the PHP version or something like that that no longer supports what the code did well. I hope it’s not an issue that since our website has a certain amount of traffic, they do everything possible to make us switch to the payment format…

Your domain is hosted on GoogieHost, not InfinityFree. Please contact GoogieHost for assitance.



I have transferred the DNS to another provider since 48 hours ago. that my website has problems beyond my control, with the direct responsibility of infinityfree and without giving me a solution, first because they have attacked the servers and when they solve it my code is already depreciated, who knows why the rules of the game changed by infinityfree. so I’m going to another provider… You can close this topic as NOT SOLVED or that the solution was to go to another provider…

You didn’t give enough time for neither the community nor InfinityFree staff members to look at your issue, which means it will never get solved.

Anyways, if you decide to go to another hosting provider, it is your choice.

FYI, usually “depreciated” does not mean “removed”, and it should still work as intended.


Let’s see. If I decide to stay in InfinityFree, the solutions should be within 24 hours. As they say, it’s been 48. On the other hand, I have another website within the same account with the same DB reading code and it turns out that that one works without problems and the sondifuzo one doesn’t, I’ll try to set the DNS as they were, but give me a solution…

You have already switched your hosting provider, which means nobody here can help you to check your code, or debug your website. The error message you provided isn’t informative either.


The DNS are already restored, the issue is that when loading the page it says that the dynamic way of arming data output is deprecated (it is an MVC), but the strange and suspicious thing about the case is that the same code in nf (also mine) works OK without giving that error. Until the moment that infinityfree had its sondifuzo server problems, it was working OK and now it’s not…

The DNS are in ns1 & ns2 epizy. Now send me solution for me…

I don’t see much of an issue? There is nothing loading wrong on the frontend?
Mind enabling error debugging on your code?


You have given no enough information yet, please show a screenshot.


Yes. Dynamic properties are deprecated in PHP 8.2:

One solution is to have the classes affected explicitly declare that they allow dynamic attributes. This thread from Stackoverflow could help:

If you’re using some script that uses dynamic properties, you’ll need to make sure you’re on the latest version, and ask the script’s authors for help with this if the latest version has issues.


The code is ok, this same code was developed by me and functional until infinityfree had problems with its servers. Currently the dynamic construction of the database data works perfectly on a subdomain within infinityfree under, what is the reason why the problem was caused by infinityfree?

Did you see that part where PHP developers themselves and not InfinityFree put the deprecated note on Dynamic properties?


Well no, I see that they will not give me a solution, I am testing the same code under a subdomain with the same characteristics at all levels in as soon as the ssl certificate is active we will see who is right, my code or the internal configuration from the infinityfree server, yes, if my code works, what will infinityfree do with the host configuration?

One more time, read the stackoverflow article linked above :slight_smile:
Reason why it works on another subdomain is probably because the host server has not been upgraded to PHP 8.2 yet.


Let’s see, how many times do I have to repeat that the error in another subdomain with the same characteristics and PHP version (7.4.8) within infinityfree works? It seems you don’t understand where the problem comes from…, don’t always tell me the same thing without knowing when the error occurred, which is precisely when infinityfree had problems with attacks on certain IPs, when solving the problem my problem with the site began. …

And what version of PHP is your main website on?


PHP 7.4.8