CSS files not found but works locally?

I created a website using WordPress and it works correctly.

I have tried to export using Simply Static which works locally when I open the index.html.

I have put the same exported files into both folders below but the page is only displaying correct on fewcharecords.epizy.com - not fewcharecords.com

fewcharecords.com - it looks like it cannot find the css files.

I think it could be related to 2 things.

  1. cloudflare ssl is enabled and was working on fewcharecords.com - with the new host files, now it appears not to be working.

  2. I have set up my domains/addon domains wrong?

It’s only working sir on epizy.com but not on your .com domain. Try clearing your browser caches.

The reason why your .com domain is not loading the css because your site has a mixed content. Consider enabling the Always Use HTTPS and Always rewrite HTTP on your Cloudfare Dashboard.

1 Like

I have refreshed the cache my side but no joy, wouldnt be a cache issue if you also see the same issues on fewcharecords.com right?

I am wondering if there are some settings on Simply Static I need to change so it has the correct paths for https://

Your SSL Protocol is having an error and it is because of the mixed content and mixed links. That is why your .com domain is not loading well.

About this one:

Mixed Content: The page at 'https://fewcharecords.com/' was loaded over HTTPS, but requested an insecure image 'http://fixadesign.epizy.com/wordpress/wp-content/uploads/2020/06/fr-logo2-1024x1024.png'. This request has been blocked; the content must be served over HTTPS.

The .com domain requested an image from epizy.com instead of only on your .com domain.

Some ways to fix:

thank you! I looked over on cloudflare further and enabled this option


Encrypts traffic between the browser and Cloudflare

Appears to have worked my side now, page loads but no ssl. which is better :slight_smile: now i can try work out how to get the ssl working again

this is how it is now

Enable the Always Use HTTPS and Always rewrite HTTP in cloudfare. Read the above updated.

1 Like


hmm i dont see this option?

On the “Edge Certificates” section of the SSL/TLS page there are those options.

Ok i found that option its on the ‘edge’ tab.

I enabled Always Use HTTPS but the page (fewcharecords.com) only gives this error.

Error 525 Ray ID: 5a4545f15c880026 • 2020-06-16 14:38:12 UTC

SSL handshake failed

I have disabled the force HTTPS for now as its the only way I can get the page to display with this index.html file.

I tried to locate the line you mentioned “https://fixadesign.epizy.com/wordpress/feed/” - I cannot find this?! not sure it would help in this situation but will try anything.

make it flexible.


oh dear going from bad to worse here.

now the page does not display on mobile devices?! looks good from a browser and also on developer tools.

cleared cache on mobile and pc already. not sure how these changes have stopped mobile view loading but desktop still works.

First, please remove the epizy.com subdomain on your cpanel.

And after removing, reinstall the wordpress on your website with https://

Make sure to have a backup of your photos before removing and reinstalling. We’re getting an error here cause you have installed the wordpress to your epizy.com instead of your .com domain.

i dont mind trashing this so I have removed epizy.com and I am reinstalled WordPress. I notice this option when reinstalling, shall i change the protocol at this stage or leave as http?

Correct remove it and change the protocol to HTTPS since you have https right?

1 Like

Yep I tried but it shows this error, shall i ignore and proceed?