Could'nt install InvoicePlane through Softaculous

i have tried many times to install invoice plain, it will be done perfectly, but not work!

successfully installed

I don’t know why it redirect ?!

please help me about installing

Many people seem to have a problem with InviocePlane. The cause looks like a bug with the software.
For InvioceNinja, it won’t work. See here:

I suggest you use some other sort of CMS.


ooh ! Is there any way to solve or contact Softaculous ?

Why anybody not responding ? :thinking:

@Admin Please help me !

May i know is this requirment available ? Requirements - InvoicePlane Wiki

There’s no need to be blind to don’t see these, you already have gotten the answer.

1 Like


The fact that you’re redirected to makes me suggest that InvoicePlane doesn’t like the webserver setup we have. It incorrectly (and naively) assumes that the SERVER_ADDR parameter is the public domain name of your account, but that’s not true in our system.

PHP >= 7.0 (PHP 5.6 may not be supported any longer)

php-mcrypt is no longer available with PHP 7.2 and later. So this means only PHP 7.0 and 7.1 are supported, but we only offer PHP 7.4 (the latest version).

So either the requirements are not true or the software doesn’t work on the latest PHP.


Wait, you can’t use ` operator? I used it to fix Xenforo that uses shell_exec, exec and proc_open

have you tried installing other things apart from that? because if so you have to clean your website of the remains of those things. :face_with_monocle:

no ! web root is cleaned (sub-domian)

is there any way to solve it ?

I don’t know, I’m not familiar with InvoicePlane. It might be a configuration issue somewhere, it might be a bug in the software. I would have to do more debugging to figure that out. I can do that, but it takes time.

Support result from InvoicePlane How to install InvoicePlane through Softculous - #5 by M4rt1n - Support - InvoicePlane Community Forums

They say that there is a config file in which you can fix this (the ipconfig.php). Did you try that already?

Aside that, where are you being redirected to at Softaculous or while visiting your site?

redirect me when i visit home page

For some reason i believe there’s something in htaccess file that does the redirect, show the code inside htaccess?


## If you are using a subfolder please remove the hash in front of the line ‘#RewriteBase /subfolder’
## and replace ‘subfolder’ with the actual name of your folder, i.e. ‘RewriteBase /invoices’

<IfModule mod_rewrite.c>

  RewriteEngine On
  RewriteBase /
  RewriteRule ^index\.php$ - [L]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule . /index.php [L]
  ## Remove the hash in front of the following two lines if you want to force HTTPS
  #RewriteCond %{HTTPS} off
  #RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]


Can you find any error in .htaccess ?

Looks like Softaculous scripts issue. WordPress, Jumbla and other various scripts affected as well


New reply from InvoicePlane

How can i access "Cluster " ?