Could'nt install InvoicePlane through Softaculous

@Admin @KangJL @anon19508339


If I don’t respond it means I’ve got nothing to answer. I beg you to stop tagging everyone.

1 Like

ok! Do you know anything about Cluster ?

From Computer cluster - Wikipedia, but there are other definitions in technology on the cluster argument:

A computer cluster is a set of loosely or tightly connected computers that work together so that, in many respects, they can be viewed as a single system. Unlike grid computers, computer clusters have each node set to perform the same task, controlled and scheduled by software.
Clusters are usually deployed to improve performance and availability over that of a single computer, while typically being much more cost-effective than single computers of comparable speed or availability.

Also, we don’t allow full web server access on free hosting, so this problem can’t be solved by changing the public cluster hostname. It may be a problem of the code used to detect the domain name, which is in this case the SERVER_ADDR parameter, but in our system it isn’t true.


infinityfree Says ask this qustion to InvoicePlane , its the problem depending on InvoicePlane.

And InvoicePlane says that , its the problem with hosting company, ask to them

Here is the example message from invoicePlane (Recieved now)

Ask at infinityFree for support. This is 100% not related to InvoicePlane itself.
I never had this issue and can not debug it, if you do not host it on your own server, but instead on Softculous.

Just call/write them and ask for, if they can check for some configurations that redirect to .
I can not help here much

Can you try a manual install?
(idk whether it will help,but lets try)

i have tried manual installation .
But failed !

the main issue is filemanager take more time to upload all files

use a ftp client,coz the ftp file managers aren’t that good


How ?

Could you please explain !

Simply download Filezilla and check Articles in InfinityFree knowledge base.


i think , is it available at Softculous
Softaculous is not available now !
so iam going to read your articles

I just tested a manual install and I couldn’t get it to work either. It seems the way the config is loaded into the application doesn’t work for some reason. It’s not entirely clear to me why.


i think you also tried to install ?!
Thank you for trying…

Yes, I tried to install and didn’t succeed.

Actually, there may be one workaround, let me check and get back to you.


ok Thanks for your responsibility

OK, so I tested my workaround, which worked!

To make InvoicePlane work, you need to make a small change to the source code. In the main index.php on line 32, you’ll find this code:

return getenv($env_key) ? getenv($env_key) : $default;

This doesn’t work for some reason, getenv never returns the correct setting. But it does work if you replace this line with the following line instead:

return !empty($_ENV[$env_key]) ? $_ENV[$env_key] : $default;

I also have a hunch as to why it’s broken. But I’ll have to eat my hat if I’m right. So… I want to be sure.

Actually, never mind, doesn’t work. It works for the URL, but not for the database setting.

So, final statement, the reason this doesn’t work is that this application relies heavily on the putenv and getenv functions to load configuration. The thing is that the putenv function is disabled on our hosting, so this won’t work. The “right” would be to use the $_ENV variable to load the environment settings from, which doesn’t require these functions.

So you’d either have to patch the whole application to not use getenv anymore. Or upgrade to premium hosting instead where this function is available.


Thanks, that worked well!


Have you also see the same page ?

All I see is that there’s a misconfigured mysql configuration file. As Admin wrote. Either use another application or upgrade to premium.

1 Like

Thanks for your reply

now almost working…
but failed to connecting database in setup page :thinking: