Cloudflare https site not displaying correctly

Hi, I am looking into Cloudflare for the SSL and for some reason the HTTPS version of the site shows up with its format all wrong:

• It should actually show up like this:

I’ve tried the Cloudflare WP plugin but I don’t know how to use it in connection with infinityfree (since rather than a user in CF I followed the recommendation to activated it via the cPanel).

Any tips on this? Perhaps I should just give it a few hours to correct itself? 



do you have a green lock or not in the browser ?
or browser report it as mixed content?

try deleting cache both in browser and cloudflare

or give us the address of the website so we will immediately know what the “problem” is

The website is — I do get a lock in the browser. I don’t know if I can clear Cloudflare cache because I’m using it via the cPanel, is there a way to do it?

Please let me know if you find out what the “problem” is, I would be so happy to get this SSL thing out of the way!

Also, as an option, you could use http to https htaccess rewrite url rules, or force all traffic to https via cloudflare panel, but first check this out:

RMP-RMP said:
The website is — I do get a lock in the browser.

yeah,as I have assumed your site was on https
but a lot of resources in its code are loaded as http
and the browser naturally refuses to load anything that is not https
That's why the appearance of your page is broken
(blocked loading mixed active content)
do as you have been told by MrJunior

Thank you both, your guidance has helped me fix this issue. I actually switched from another free host where I had ran into other complications with SSL also. But my https is working fine now thanks to you guys :slight_smile:

I wonder about one more thing, and I’d like to take this opportunity to ask: I’m thinking of activating a second site with infinityfree+cloudflare; do you expect there to be any issues if I were to use the same email account (Cloudflare appears to not work via cPanel if the email is already registered)?

Adding new domain should immediately add it to integrated cloudflare panel as i know, and yes we’ll be here and ready to help you out

Hi there guys! It’s me again. After the downtime a few days ago my site is still not showing up (getting error 522).

I’ve tried to fix it myself but found I’m not as savvy as I thought… I tried what was suggested in post Website still down, but couldn’t find where to modify the DNS (I did go to Registrar and I got the epizy DNS looking good, and this goes to CloudFlare – should I change something in CloudFlare via cPanel?).

Now as I’m writing this, the site is back up and I was able to update a couple WP addons, but after that it shows error 522 again.

Hi and WB

Its working on my end (I believe you managed to solve the problems)

Hey OxyDac, thanks for all the help.

It’s weird, at certain times I keep getting the 522 error. Now for example it’s not loading the site for me.

I tried something you suggested in another post but I’m not quite clear on how to do it really…

Can you help me out?