Can't connect to database error (wordpress)

Hi !

I’am using wordpress on inifinity free and everything used to work fine.
But today, when I try to connect to my website, I get an error telling me that the connection with the database is not working.
I double checked my login and the database url, but nothing changed.
It is weird because I changed nothing since the last time it worked, and I can connect the database with phpmyadmin is chrome.

Any idea to solve the issue ?

Thank you

My website URL is:

I would recommend you read this.
It lists some simple steps on how to troubleshoot that error you are getting.

@philippe27, here and here are the solutions to your problems.
@Magnus, you had to read the Knowledge Base before posting, as they might be links with tutorials to solve the problems!

Hi @Magnus and thank, but I know how wordpress works and it didn’t help.
@Ergastolator1 I am thinking that data may be corrupted and I will try to retore a backup.

Nothing changed since the last time it worked, which is weird.

Here is the error I get with a custom php script:

Erreur : SQLSTATE[HY000] [1045] Access denied for user ‘epiz_23966693’@‘’ (using password: YES)
N°: 1045

I double checked that the password was the cpannel password, and the database name is matching with the one in cpannel. (epiz_23966693_wordpress)

Are you sure the password inserted was the one you’ve showed before accessing the Control Panel on the Client Area’s Account Management Page, and not the Client Area one?

Yes I am sure it is the right password.
Because I didn’t edit anything since the last time it worked, would it be an issue from infinity’s side ?

I don’t know, but maybe it will be that the database permissions are broken, as shown here on this paragraph:

Ask on the forums for your database permissions to be reset

In some extreme cases, none of the suggestions above work. If that happens, it’s possible that the database permissions on your account have been corrupted, and will need to be reset. If you have tried all the methods above and still can’t access phpMyAdmin, please ask on the forum for staff to reset your database permissions.

It is likely that the database is broken because I can’t connect to phpMyAdmin anymore.
I am going to reset the database.

You can’t reset the database permissions on your own. You will need to wait for the Admin to do it.

I did it by deleting the entire databse and recreate it. I know this is the “bad” way to do it, but it is much faster.
Now it seem that wordpress can conect the database, but I get “ERR_TOO_MANY_REDIRECTS” on the phpMyAdmin page.
Edit: Clearing cache solved the issue.

Everything is working now, thank you very much !

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.