Cannot restore forum site from backup

Username (e.g. epiz_XXX) or Website URL

(please specify the website or account you are asking about)


Error Message

(please share the FULL error message you see)

Other Information

(other information and details relevant to your question)

There is an update from MyBB that worked fine in my forum on localhost, it didn’t work on the website forum. The update is from ver. 1.8.24 to 1.8.25, I have done these updates two times before with no problems (1.8.22 to .23, then to .24) for whatever reason this one to 1.8.25 failed. I have an error message from the attempted installation, but I’d like to restore the forum site first and retry the update. This is a very small forum that’s not very active with only a dozen members, but I’d like to get it back up and functioning.

Thanks for your responses :slightly_smiling_face:


Hmm, can you remove that file and try again? (the place holder ‘your files should be uploaded here’)

And regarding the update, i would appreciate if you show the screenshots of that error.

I tried to find that file to see if I could change the protection, or do something with it using file manager, I couldn’t find it.

There are two files under htdocs/home/vol5_8/ and softsql.sql.

Can you help me find the right file file?

Next post will be the update failed error message.

What’s your website url?

Failed install error message and recommended actions from MyBB docs below that. I did verify the two entries $config [ ’ database ’ ] [ ’ database ’ ] and $config [ ’ database ’ ] [ ’ username ’ ] were what they should be according to my account information. from cpanel

Well, what about sharing here (with censoring your password?)

This can happen either because the hostname is incorrect, or the password or wrong database name.

@anon19508339 here is the inc/config.php from file manager under htdocs/inc. I did try removing the _5 from the $config [ ’ database ’ ] [ ’ username ’ ] = ’ 24838458 ’ ; it made no difference, I put it back the way I found it.


if it helps you


Thanks @Oxy :slightly_smiling_face: the MyBB forum was the first place I looked for any install update posts. Here’s some information about where I got some of the screen shots from.

The screen shot in post #5, I clicked on the link common issues and it took me to here FAQ - MyBB Documentation I clicked on Error Messages, Common MyBB error messages and how to fix them. That’s where the screen shot/snip came from.

The reason I came here first was I did install MyBB through Softaculous, when I attempted to restore the forum that failed. The backups were done using Softaculous, and I tried to do the update through Softaculous too, both update and restore failed. I went to the MyBB site and downloaded the update package from this page Version 1.8.25 - MyBB I have tried both packages and they both fail with the same result.

The way I’ve installed these updates in the past from the MyBB page has been to download to my computer, unzip it, then open Filezilla, highlight those files and upload them to htdocs. Then open the forum page, change the URL to and it takes you to a page where you can choose a clean install or the update install. The update install has worked well, and took just a few minutes to update the forum the last two times I’ve done it.

according to this only these two files have been modified (changed files)


Do you have access to the admin panel from the forum?
enable error logs ?


You can use phpMyAdmin
and compare the names of DB and the rest if it is the same as the one contained in the config

I remember that :slight_smile: Added MyBB to server, would like to remove wordpress


The update was a minor one, 1.8.24 to 1.8.25, I didn’t have to do it, there were no problems with the forum, but I think it should be on the most recent release.

I can’t access the forum at all, I get the first message below. Then below that is a small snip from phpMyAdmin showing the server and database. Farther down is the screen I get when I use /forum/install to star the install of the update. I have always chosen the Upgrade my existing copy of MyBB to 1.8.xx, this time when I click that button instead of an install screen I get the MyBB SQL Error message screen shown in post #5



Important Update: In an attempt to do something to resolve the issue I used Filezilla to upload MyBB ver. 1.8.24 to the htdocs folder and was able to successfully update/install MyBB 1.8.24, the forum is up and working normally. :sweat_smile:

Performing reinstall of the existing version worked is as good as a backup, all forums, users, configurations, etc… are present. :grinning:

I’ll attempt to upgrade/update to MyBB 1.8.25 in a little while, at this time I’ll mark this thread solved. Thanks very much to @anon19508339 and @Oxy for your contributions, I always learn things when I’m working with you two :star_struck:

Edit: Attempted an update/install to version 1.8.25 with the same results, failed showing the same error message. Performed an update/reinstall of 1.8.24 with no problems or errors and the forum is back up.

It works fine right now, I’ll stay on ver. 1.8.24 and keep an eye on the MyBB forum for any new information.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.